Download manager truncates filename (ie Class_Schedule_2004_Fall.doc becomes Class.doc) when downloading attachments from yahoo mail

VERIFIED DUPLICATE of bug 252309

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 252309
13 years ago
13 years ago

People

(Reporter: Pedro Pinche, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Email file attachments download through yahoo's web based email at
mail.yahoo.com are automatically trucated when they have as spaces or
underscores in the filename.  

Examples:  Class_Schedule_2004_Fall.doc becomes CLASS.doc ;  new info 5.doc
becomes NEW.doc

Here is the HTML code used to initiate the download via a button labeled
download attachment.  I have trucated the msgid for privacy reasons.

<button type=button
onclick="window.location.href='/ym/ShowLetter/?box=Inbox&MsgId=5644_31573266_905&bodyPart=5&filename=&tnef=&download=1&YY=87288&order=down&sort=date&pos=0&view=a&head=b'">Download
Attachment</button>

Reproducible: Always
Steps to Reproduce:
1. Go to yahoo mail.
2. Click download attached file.
3.

Actual Results:  
Download manager truncates the file name at the first space or underscore.

Expected Results:  
Should have displayed the full file name.  I.E. class_2004_fall.doc should be
class_2004_fall.doc not CLASS.doc

Comment 1

13 years ago
All file names have spaces, the underscores are only for display by yahoo (see
bug 252309 comment 0 step 4). It is the issue from bug 221028. To evangelize we
have already a bug for yahoo, so marking as dupe.

*** This bug has been marked as a duplicate of 252309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.