Input in other tab with focus steals characters typed in current tab

RESOLVED DUPLICATE of bug 124750

Status

()

--
major
RESOLVED DUPLICATE of bug 124750
14 years ago
14 years ago

People

(Reporter: maps, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I first thought this was a bug in Find as you type, but it turns out to be more
general.

Reproducible: Always
Steps to Reproduce:
1. Open our intranet homepage, which has an "onLoad" event which gives focus to
a text input.
2. In another tab, open some other page that doesn't have a form.
3-a. Start typing "foobar".
3-b. Hit ctrl-f, then start typing some text that should be found on the page.

Actual Results:  
3-a. The text "foobar" appears in the search input on the previous tab.

3-b. The first character or two of your find text shows up in the FAYT bar, then
the rest of the characters show up in the input on the previous tab.

Expected Results:  
3-a. Nothing

3-b. Text entered should show up in FAYT bar.

Installed extensions: DOM Inspector, Download Manager Tweak, Web Developer, View
Cookies, FlashBlock.
One of the many reasons you should update to 1.0

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.