Non-privaleged user has to use -safe-mode to start Firefox after a fresh install. Privaleged user can start Firefox.

RESOLVED DUPLICATE of bug 259978

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 259978
14 years ago
13 years ago

People

(Reporter: Barry Wright, Assigned: Blake Ross)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Fresh install of firefox-1.0.installer.tar.gz on Fedora Core 1 linux client.
Installed with no problems into /opt/firefox as root, at completion browser
started okay. No extensions or themes present. Closed browser and logged in as
unpriv user, screen scrolled with

*** loading the extensions datasource
and
(firefox-bin:18597): Gdk-WARNING **: Error converting from UTF-8 to STRING:
Conversion from character set 'UTF-8' to 'ISO-8859-1' is not supported
and
(Gecko:18597): libgnomevfs-WARNING **: Cannot create pipe for GnomeVFSProcess
initialization: Too many open files
messages until it finally failed with
Fontconfig error: Cannot load default config file
/opt/firefox/run-mozilla.sh: line 451: 18597 Segmentation fault      "$prog"
${1+"$@"}
 
Non-priv user could start firefox with -safe-mode, there were two lines of
*** loading the extensions datasource
in the terminal window, closed Firefox.

Logged back in as root and downloaded Flash Got and Image Zoom  extensions,
closed Firefox and logged in as user, -safe-mode no longer needed but still get 
 *** loading the extensions datasource
messages.

Deleted Firefox installation from /opt/firefox
Fresh install of Firefox as root, with root's .mozilla left intact.
Client can now start Firefox without errors, client does not have any extensions
or themes.

Reproducible: Always
Steps to Reproduce:
1.Fresh install of Firefox 1.0 as linux priv user.
2.Login as unpriv user and start firefox without any flags.
3.

Actual Results:  
Firefox would not start, error messages detailed above, ends with a seg fault.

Expected Results:  
Firefox starts without error messages.
Assignee: general → firefox
Component: Browser-General → General
Product: Browser → Firefox
QA Contact: general → firefox.general

Comment 1

13 years ago
Please, could you see if your bug is a duplicate of bug#259978
and test if the attachment in bug#272324 solves your problem?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Please, could you see if your bug is a duplicate of bug#259978
> and test if the attachment in bug#272324 solves your problem?

Apologies for significant delay in replying.

I believe that this bug is a duplicate of 259978 as  "*** loading the extensions
datasource" is repeated approximately 125 times before the seg fault.
The patch to components/nsExtensionManager.js (from bug 272324) resolves this bug.

As a side issue we have been testing against Fedora Core 3 and have not been
able to reproduce the bug with a clean install of firefox-1.0.installer.tar.gz.

*** This bug has been marked as a duplicate of 259978 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.