request for functionality: to view or save attachments/files within .eml (message/rfc822)

RESOLVED DUPLICATE of bug 284381

Status

RESOLVED DUPLICATE of bug 284381
14 years ago
10 years ago

People

(Reporter: eagle.lu, Assigned: nian.liu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla 1.4 (and also all earlier and later versions) does not provide the
ability to view or save files contained within a ".eml" file.  This
functionality is available in Netscape 4.79. 


To reproduce this problem:

(1) First we need a ".eml" file which contains an attachment:
- Open up Mozilla, click Window->Mail & Newsgroups
- File->New Message
- Fill in the "To" field with a test email address (e.g. test@test)
- Click the "Attach" button
- Select a binary file
- File->Save As->Draft
- Close the compose window
- Select the "Drafts" local folder
- Select the draft message that was just created
- File->Save As->File
- Save the file somewhere (e.g. blah.eml)

(2) Open the .eml file in the browser:
- Open up a Mozilla "browser" window
- File->Open File...
- Select the ".eml" file created at (1)

This will display the email message created above - the attachment's filename
will be displayed, but there is no capability to "save" or view it.
When you open a ".eml" file in Netscape 4.79 there is the capability to View or
Save the attachment.

Comment 1

14 years ago
Looks like Bug 174692 (is for the display in the Browser window but is product
Mailnews, see Bug 174692 comment 14). 
(Assignee)

Updated

14 years ago
Assignee: general → nian.liu

Updated

14 years ago
OS: Linux → All
Hardware: PC → All
Summary: request for functionality: to view or save files with .eml → request for functionality: to view or save attachments/files within .eml (message/rfc822)
Product: Browser → Seamonkey
This would need to be done in the appropriate converter, which is in the
mailnews module.
Component: General → MailNews: Networking
Product: Mozilla Application Suite → Core
Boying Lu(reporter of this bug), please list this bug in Bug 269826(meta bug) if
your problem is not DUP of any bugs listed in Bug 269826.
Depends on: 269826
Blocks: 269826
No longer depends on: 269826

Comment 4

14 years ago
Dupe of the new Bug 284381?
(Assignee)

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 284381 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
No longer blocks: 269826
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.