Find should scroll as far leftward as possible while showing the match, and show more lines of context

RESOLVED DUPLICATE of bug 171237

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 171237
13 years ago
9 years ago

People

(Reporter: t t, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0 (Debian package 1.0-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0 (Debian package 1.0-2)

Find-as-you-type, such as invoked with "/", scrolls horizontally to
show you the text, and puts the text at the bottom of the screen.

This requires the user to (a) scroll left using the mouse and (b)
scroll down using the mouse just to show context.  Then, to start the
search again, the user has to do the same thing, over and over, just
to see context.  If the user uses Emacs, C-a is a natural.  But even
if emacsy settings are made, C-a selects all the text on the page.

The result is that for large documents it's easier to save the
document and use less(1) instead!  And then do it again for every
other document that needs finding!

The solution is to default to show context around the found text, and
scroll as far leftward as possible while showing the text by default,
and allow the user to set C-a to work as in Emacs.

Thanks.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
fwiw, all the arrow keys and pgup/dn scroll fine over here, while
finding-as-you-type. linux fx1.0

How is maintaining the horizontal scroll as far left as possible while showing
matches, signifigantly better? You'd be missing more of the right-side context then.
Summary: Find is highly non-ergonomic → Find should scroll as far leftward as possible while showing the match, and show more lines of context
(Reporter)

Comment 2

13 years ago
WRT right context, my experience is that

1.  It shows no left context at all
2.  There typically IS more left context -- ragged right is the norm
3.  You get to read what's going on if you're scrolled to the left;
    you have a useless rectangle of text (mostly the ends of lines, plus a few    
    that require further scrolling) if you're not.

FWIW

Comment 3

12 years ago
For friendlier vertical positioning see bug 263447.

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 171237 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.