If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When a new profile is created, there is no userChrome.css / userContent.css of a sample.

RESOLVED WONTFIX

Status

Thunderbird
General
--
minor
RESOLVED WONTFIX
13 years ago
7 years ago

People

(Reporter: Hiro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [add-on idea], URL)

(Reporter)

Description

13 years ago
Like Firefox, when a new profile is created also by Thunderbird, there should be
a customize file of a sample.

Reproducible: Always
Steps to Reproduce:
1.Create new profile.
  Migration does not perform.
2. Look %profiledir%/chrome

Actual Results:
There is no sample of userChrome.css/userContent.css.

Expected Results:
There is  sample of userChrome.css/userContent.css.

Thunderbird version 0.9 (20041103)
(Reporter)

Comment 1

13 years ago
Mac version Tb 1.0 Release doesn't have these files either. 

Change Hardware & OS -> All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

12 years ago
I understand from <http://www.mozilla.org/unix/customizing.html> that the userChrome.css and userContent.css are absent by default. The userChrome-example.css and userContent-example.css files should be present by default.

Reporter (Hiro): Which files do you believe are missing? If your chrome folder contains userChrome-example.css and userContent-example.css by default then perhaps everything is OK and there is no bug?
(Reporter)

Comment 3

12 years ago
> Reporter (Hiro): Which files do you believe are missing? If your chrome folder
> contains userChrome-example.css and userContent-example.css by default then
> perhaps everything is OK and there is no bug?

A meaning of a sample file is userChrome-example.css and userContent-example.css.

I checked 1.8branch NB.
A "chrome" folder was not made with this version by Profile, too.

An empty chrome folder was ready in Profile before.
But now, this folder is not made, too.

If customization is possible in Thunderbird, I think that I had better prepare a sample file as well as Firefox like URL.

Mac OS X 10.3.9
version 2 alpha 1 (20060607)

Comment 4

12 years ago
 I agree that the *-example.css files should be present by default.

 The issue with the chrome folder not being created seems to be fairly recent and is reported in Bug 335423. A fix for Bug 335423 may also fix this bug (someone with the appropriate bugzilla privs could add Bug 335423 to the dependency list for this bug, if that's a sensible thing to do).
QA Contact: general

Updated

9 years ago
Assignee: mscott → nobody
Depends on: 335423
wontfix per standard8.
"the "usefulness" of supplying the example files, and installing them in everyone's new profile versus those people who will actually use them and find them useful, is going to be a pretty small ratio to those that use them. Hence I don't think its worth the effort"
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
See Also: → bug 335423
Whiteboard: [add-on idea]
You need to log in before you can comment on or make changes to this bug.