Closed Bug 270146 Opened 17 years ago Closed 17 years ago

file upload input element does not accept CSS class attribute

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: leandro.hermida, Assigned: dbaron)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If you have the following HTML code in a form:

<input class="myclass" type="file" name="file_upload">

and the CSS class in the css file is something like:

input.myclass {
    width: 100%;
    padding: 15px;
}

Firefox, Netscape, and Mozilla do not display the element based on the css
attributes given.  The file upload input element does not have the correct width
or padding.  It seems that some css attributes (like background-color) are done
properly but others are not so all I can say is that there is some kind of bug
with the way file upload input elements accept the css class they are given.



Reproducible: Always
Steps to Reproduce:
1. Create form and file upload input element with css class="myclass"
2. Make css class myclass in <style></style> tags or external css file and set
attributes such as width and padding
3. View web page in Firefox and you will see that it incorrectly displays or
does not accept css class attributes



Expected Results:  
It should properly display the file upload input element based on the css
properties it was assigned.

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Component: Style System (CSS) → Layout: Form Controls
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.