Blank empty square replaces favicon when preferences are set to "do not display images"

RESOLVED DUPLICATE of bug 253238

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED DUPLICATE of bug 253238
14 years ago
5 years ago

People

(Reporter: Rastignac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When FireFox preferences are set to "do not display images", the tabs show empty
blank squares and not the favicon or the default bookmark icon.

Reproducible: Always
Steps to Reproduce:
- Set FireFox to display the favicons.
- Set FireFox to display “all images”.
- Go to http://www.google.fr
- Look that the tab displays Goggle’s favicon.
- Now set FireFox to display “no images at all”.
- Open a new tab.
- Go to http://www.google.fr
- Look that the tab now displays an empty blank square and not the favicon or
the default bookmark icon.
Actual Results:  
Blank empty square where favicon should have been displayed.

Expected Results:  
Favicon must be displayed whatever the images display preference is set.

That’s a regression. Previous versions of FireFox performed correctly. Note that
the same regression also appears in the recent alphas of Mozilla 1.8.

The browser should/must display the favicon whatever the “images display”
setting is. Displaying an empty blank square is not a good behavior.

Comment 1

14 years ago
WFM in the same build.
(Reporter)

Comment 2

14 years ago
Created attachment 166211 [details]
Screenshot showing the bug ("favicon / no favicon" with the same site)

Here is a screenshot showing the bug. All the tabs are the same site. When
"display images" is set to "no", the tab shows a blank square and the urlbar
shows the default bookmark icon. When "display images" is set to "yes", the tab
and the urlbar show the favicon.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
I think that this is a duplicate of the bug 253238.
Assignee: bugs → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 253238
You need to log in before you can comment on or make changes to this bug.