Filter problem in LDAP replication

RESOLVED DUPLICATE of bug 231965

Status

RESOLVED DUPLICATE of bug 231965
14 years ago
13 years ago

People

(Reporter: bertrand.croq, Assigned: mscott)

Tracking

1.7 Branch
Other
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)
Build Identifier: 

http://forums.mozillazine.org/viewtopic.php?t=149093 says: 
 
Hello!  
  
 I'm having trouble getting addressbook ldap replication to work (download 
copy of directory for use locally/offline).  
  
 In TOOLS => OPTIONS => COMPOSTION => DIRECTORY SERVER: EDIT DIRECTORIES, I 
have successfully configured a connection to an LDAP directory. It works fine 
for autocompletion of addresses in a new message window and when performing 
searches in the addressbook. However, when I select the LDAP directory in the 
main addressbook window, no addresses show up on the right.  
  
 However, in the OFFLINE tab of the DIRECTORY SERVER PROPERTIES window, it 
says that "You can download a local copy of this directory so that it is 
available for use when you are working offline." But when I click DOWNLOAD, 
I'm not sure what USER NAME and PASSWORD I'm supposed to supply, I've tried 
many combinations, including the bind dn ad password, but nothing seems to 
work.  
  
 I'm running Thunderbird 0.8 on Debian 3.1 (kernel 2.4.27-1-386)  
  
 Thanks in advance for any help you can provide.  
  
 Steven 
---- 
 
I have the same problem, tested with Thunderbird 0.8 from Debian Sid, and with 
Thunderbird 0.9 on Windows XP. 

Reproducible: Always
Steps to Reproduce:
In the properties of an LDAP directory, ask for a local replication. 
Actual Results:  
- I get the user/password dialog 
- the LDAP filter used for the query is invalid "(uid=)" 

Expected Results:  
A local replication of the directory

Comment 1

14 years ago
is your ldap server configured to return an arbitrarily large number of entries
for an ldap query? Many LDAP servers don't, and that breaks ldap replication.
(Reporter)

Comment 2

14 years ago
It doesn't seem to be a server related problem... this openldap server doesn't 
contains lots of entries (6 addresses) and is already used since monthes but 
postfix and dovecot. 
 
I sniffed the communication between Mozilla and the LDAP server with ethereal, 
and the filter used to search the entries was "(mail=)"... sorry, I wrote that 
the filter was "(uid=)". 
 
Here is a more complete description of what happens: 
- I open the "Properties" dialog box for the LDAP directory and go to the 
"Offline" tab 
- I click "Download Now" 
- here, the LDAP server gets a bind request 
- then Mozilla displays a user/password dialog, that I submit without filling 
any input 
- the LDAP server gets a search request with a "(mail=)" filter (slapd debug 
doesn't recognize this filter) 
- Mozilla displays once again the user/password dialog, I put "bertrand" in 
the login input 
- the LDAP server gets a search request with a "(mail=bertrand)" filter... 
this is a valid filter, but I don't understand why such a request. 
 
If I give "*" for the login, the LDAP server sends some results, but as the 
search request only requested the "cn" attribute, it doesn't give really 
useful informations to Mozilla... Mozilla then returns to the "Properties" 
dialog without any error. 
 
I hope it helps. One last thing: this bug affects mozilla-mailnews and 
mozilla-thunderbid. 
(Reporter)

Updated

14 years ago
Component: Address Book → Address Book
OS: Linux → All
Product: Thunderbird → MailNews
Version: unspecified → 1.7 Branch
Product: Browser → Seamonkey
This probably isnt a filter problem in LDAP replication. It is more likely an
auth problem somewhere. The patch on bug 231965 will fix your problem. Therefore
duping to that one.

*** This bug has been marked as a duplicate of 231965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.