Appearance of existing table rows changes when displaying a previously undisplayed row

RESOLVED DUPLICATE of bug 270192

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 270192
14 years ago
14 years ago

People

(Reporter: Goetz Heller, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

In a table with two columns a table row's display style property is to be
switched on and off by means of JavaScript code. This row contains just one cell
with its colspan set to 2, and it is the first such row following a couple of
rows each containing two cells. After loading the page to the browser, the box
in the bottom is unchecked, and the row's display style property has value
'none'. Everything looks nice.

Reproducible: Always
Steps to Reproduce:
1. Check the box in the middle at the bottom at the page.

Actual Results:  
An additional row is displayed, and the appearance of the row above changes.
The new row displays as if it had to cells.

Expected Results:  
The row above should remain unchanged, and the contents of the new row should
extend to the whole table width.

In IE 6, the page behaviour is as desired.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 270192 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.