If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Switching display style of stacked DIVs on and off does not work.

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Goetz Heller, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

Content on this page is to by exposed and hidden via stacked DIV elements the
display style property of which is switched on and off by means of JavaScript
code to mimic navigation experience.

Reproducible: Always
Steps to Reproduce:
1. Just open the URL.
Actual Results:  
The area covered by the contents of the DIV elements under consideration remains
empty.

Expected Results:  
Expose the contents of the DIV element.

With IE 6, the page's behaviour is as desired.
(Reporter)

Comment 1

13 years ago
ok, the problem was on my side - the divs under consideration had only their 
id attribute set, not the name. JavaScript's getElementById() appears to use 
the name attribute, while IE's all array works with the id attribute. I forgot 
to take this in ato account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.