Problem with comment type

VERIFIED DUPLICATE of bug 130314

Status

()

VERIFIED DUPLICATE of bug 130314
14 years ago
14 years ago

People

(Reporter: buhsl, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The FF does not like comment like <!-- -------------------------- -->
If open veiw source it looks like parser crash on that line.
In browser page look broken.


Reproducible: Always
Steps to Reproduce:
1.Create simple html file with some txt.
2. Insert in middle line <!-- ------------------- -->
3. Open file with FF. The first path before comment looks good, but after could
be removed compleately.

Comment 1

14 years ago
'--' is not allowed in the body of a comment.  See
http://www.w3.org/TR/html401/intro/sgmltut.html#idx-HTML

Each time you do have '--' you open or close the comment.  So the page display
breaks.

*** This bug has been marked as a duplicate of 130314 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.