Typing slash or ' when find toolbar is not focused enters / or ' in toolbar

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: mbrubeck, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When the Find Toolbar is visible but not focused, typing slash (/) or apostrophe
(') focuses the Find Toolbar and replaces the contents of the "Find" field with
the character that was typed (/ or ').

This bug has the same symptoms as bug 253994, which was resolved in September.

Reproducible: Always
Steps to Reproduce:
1. Type control-F to open the Find Toolbar.
2. Click elsewhere on the page to de-focus the Find Toolbar.
3. Press the slash key (/).

Actual Results:  
The Find Toolbar is focused and its contents are replaced with "/".

Expected Results:  
The Find Toolbar should be focused, but its contents should not change.

This occurs in Firefox 1.0 on Windows XP.

Comment 1

14 years ago
I can confirm this behaviour, but it is expected afaict.

'/' opens the find toolbar if it is not open and is added to the find-string if
it is open already. It *never* focuses the FT. If you need to focus the FT, use
CTRL+F.

Suggesting INVALID.
(Reporter)

Comment 2

14 years ago
Regarding comment #1, that is not the behavior I am seeing (in Firefox 1.0 on
Windows and Linux).

Pressing slash *does* focus the Find toolbar, if it is visible but not focused.
 It does not add "/" to the find string; instead it replaces the find string
with "/".

Can you confirm that you are *not* seeing the reported behavior, when following
the steps to reproduce the bug?  If so, what build are you using?

Comment 3

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0. I tried with accessibility.typeaheadfind=true and false.

'/' *never* focuses the find box for me (left/right arrows don't select text in
the textbox).

I *am* seeing the described behaviour. My opinion is that is expected.

Try these:
(i)
1. CTRL+F
2. enter search string
3. focus content window
4. press 'o'.
The search string is replaced with 'o'

(ii)
0. Make sure content is focused and that there's no FT open
1. press '/'
2. press '/' again.
First '/' opens FT, second is added to the search-box.

Therefore, I think that the behaviour described in comment 0 is correct.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> (i)
> 1. CTRL+F
> 2. enter search string
> 3. focus content window
> 4. press 'o'.
> The search string is replaced with 'o'

When I do this (Firefox 1.0, Debian GNU/Linux), the search string is not
replaced with 'o'.  Nothing happens when I press 'o'.

Note:  For step 3 (focus content window), I click in a blank area of the page
contents.

> (ii)
> 0. Make sure content is focused and that there's no FT open
> 1. press '/'
> 2. press '/' again.
> First '/' opens FT, second is added to the search-box.

(ii) works correctly on my build, and I agree that the behavior in (ii) is correct.

Comment 5

14 years ago
> > (i)
> > The search string is replaced with 'o'
> When I do this (Firefox 1.0, Debian GNU/Linux), the search string is not
> replaced with 'o'.  Nothing happens when I press 'o'.
You're right, I tried it with accessibility.typeaheadfind=false and it works as
you described. *That* is the bug, IMO. (because you already see the unfocused
find toolbar, it looks exactly as if you just pressed '/').
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 7

13 years ago
I can no longer reproduce this bug in Firefox 1.5 beta 1 (Debian GNU/Linux
unstable).  Marking FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.