windows.status method doesn't work

VERIFIED INVALID

Status

()

Firefox
General
--
major
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: Ed, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The window.status method doesn't work. To demonstrate this, type the following
URL into the browser's address bar: javascript:window.status="foo";void 0

The text "foo" should appear in the status bar, but it doesn't.

Reproducible: Always
Steps to Reproduce:
Type the following URL into the browser's address bar:
javascript:window.status="foo";void 0

Actual Results:  
Nothing

Expected Results:  
The text "foo" should appear in the address bar
Works for me: when I want web sites mucking with my statusbar, I just go to
Tools - Options - Web Features - Javascript Advanced, and check "Change status
bar text". Most of the time, I want to be able to hover a link and see the URL
in the statusbar, not see the site saying "It's a good link, click it!" or lying
to me about where the link will take me, and apparently the Firefox devs think
most people want that, so they chose not to let sites play with the statusbar by
default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.