Don't run junk controls on new feed items

VERIFIED FIXED

Status

MailNews Core
Feed Reader
VERIFIED FIXED
13 years ago
7 months ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
Sometimes when I add a new feed, I notice that several of the feed items get
marked as junk. We shouldn't run the junk mail controls on RSS folders.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird1.0
(Assignee)

Comment 1

13 years ago
Created attachment 166167 [details] [diff] [review]
the fix

This patch prevents us from calling the junk mail plugins when the server is an
rss server.

That being said I'm not ready to check this in yet because I can't get a
scenario when this method gets called when adding new feeds or getting new mail
for a feed.  So I don't know how I keep getting some feed items marked as junk.
We aren't consistently going through this routine to begin with.
(Assignee)

Comment 2

13 years ago
*** Bug 251521 has been marked as a duplicate of this bug. ***
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 3

13 years ago
Comment on attachment 166167 [details] [diff] [review]
the fix

I finally got to trigger this code when subscribing to an RSS feed.
Interestingly enough, it only seems to happen when you drag a new feed url to
the RSS account and we create and fill a new folder for the  feed. 

This patch fixes the problem by passing junk mail controls for rss folders.
Attachment #166167 - Flags: superreview?(bienvenu)

Updated

13 years ago
Attachment #166167 - Flags: superreview?(bienvenu) → superreview+
(In reply to comment #3)
> Interestingly enough, it only seems to happen when you drag a new feed url to
> the RSS account and we create and fill a new folder for the  feed. 

actually, when I was trying to repro bug 251521, I was able to repro this issue
by just copying and pasting an rss link into the Add dialog from Manage RSS
Subscriptions.

Comment 5

13 years ago
Comment on attachment 166167 [details] [diff] [review]
the fix

a=asa for checkin on 1.8a5 frozen trunk.
(Assignee)

Comment 6

13 years ago
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
haven't seen this with recent tbird builds. looks good!
Status: RESOLVED → VERIFIED
Scott, this bug isn't fixed finally I think. I have re-enabled the displaying of
unknown junk state. I can see a question mark behind every feed item. Instead
the entries should be marked as not junk. Is that correct or do I have an error
in reasoning?

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Target Milestone: Thunderbird1.0 → ---

Updated

7 months ago
See Also: → bug 1356840
You need to log in before you can comment on or make changes to this bug.