Closed Bug 27031 Opened 20 years ago Closed 20 years ago

Having intranet address in URL redirecting page on linux.

Categories

(Core :: DOM: Core & HTML, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 27339

People

(Reporter: desale, Assigned: vidur)

References

()

Details

Having this image at "http://www.mozilla.org/images/mozilla-banner.gif" is 
redirecting page to some bubblegum.com

BUILDS: 02-08-09

STEPS TO REPRODUCE:
1] Please visit URL specified above.
or 
click following link.
http://bubblegum/desale/tester.html

EXPECTED RESULTS:
We should see only page mentioned above with one image at top.

ACTUAL RESULTS:
For a moment we see the above page and then it gets redirected to some 
bubblegum.com which shows URL http://keyword.netscape.com/keyword/bubblegum

TESTCASE START:

<html>
<head><title>Testing Page</title>
</head>
<body>
<img src="http://www.mozilla.org/images/mozilla-banner.gif" width=335>
<h4>Why does this page gets redirected ?</h4>
</body>
</html>

TESTCASE END:

In a way its blocker for our automation, but I have some work around for 
automation, so I'm not marking it as blocker.
Can't recreate this on a 2/10/2000 build on Linux.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Vidur,
On my linux box I can still se this bug. I talked to Shrirang, and seems like he 
is also experiencing this one. This one does not happen on his machine all the 
time. Ha said Paul MacQuiddy also saw this one. Its not because of image. Its 
because if you type any intranet server name, like "bubblegum", or "slip" in 
location bar, then it takes you to 
http://keyword.netscape.com/keyword/servername.
In the testcase I provided, its because that image is located at bubblegum, so 
its taking you to http://keyword.netscape.com/keyword/bubblegum.
For other people, it does not happen all the time, but they've seen it 
happening.
On my linx box, it happens all the time.
I don't know why its happening, but Shrirang also saw this one. He said he saw 
it happening in Windows too.

Changing summary.
Summary: Having image in body redirecting page on linux. → Having intranet address in URL redirecting page on linux.
Vidur, I tried it with windows too. And It could be reproducible on windows too.
If you keep on hitting enter key in location bar, then at certain point it will 
happen.
Adding Shrirang to CC list.
I've seen this too, and I've filed a bug on it, it happens at http://phonebook 
also. Re-opening and then setting as a duplicate of 27339
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The key to reproduce it is to run with keywords which can be turned on and off 
in the pref panel under smart browsing.

*** This bug has been marked as a duplicate of 27339 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Duplicate verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.