If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Compose window line wrapping indents line at beginning of sentence (plain text)

RESOLVED DUPLICATE of bug 202195

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 202195
13 years ago
13 years ago

People

(Reporter: Phil Johnson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When composing plain-text messages, if the last thing on a line preceding an
automatic line wrap is the end of a sentence followed by two spaces, Thunderbird
moves the second space to the beginning of the next line, leaving the text
looking indented.

This is particularly annoying because this is not visible in the composition
window; you can only see it after the message has been sent.  This gives the
reader the misimpression that you intended to start a new paragraph.

Since it is conventional when typing to leave two spaces after the period
between sentences, this problem happens all the time.  It has always existed in
Mozilla.

In principle, if the recipient's mail client respects "format=flowed" then they
shouldn't see the leading space.  However, when the message is forwarded or
quoted for reply then the leading space is preserved, and looks wrong even when
viewed in Thunderbird.  Plus, many clients don't respect flowed format yet.

Reproducible: Always
Steps to Reproduce:
1. In the options dialog, set a line-wrap length.
2. Start composing a message.  Make sure the last word on the line, prior to the
line being wrapped, ends with a period.  Then type two spaces after the period
before starting the next sentence.
3. Send the mail to yourself.
4. When message is received, view the message source and see the extra space at
the start of the wrapped line.
5. Reply to the message, including the original message, and see that the extra
space is plainly visible in the quoted text.


Expected Results:  
Word-wrapping should never move spaces to the beginning of the line when the
message is formatted for sending.  Leave the spaces at the end of the previous line.

Comment 1

13 years ago
See also bug 223279.

*** This bug has been marked as a duplicate of 202195 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.