firefox suddenly stopped opening pdf files in the browser plug-in - launches adobe reader externally instead

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Michael, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Firefox used to open pdf files inside browser windows.  It now will only open
them in the external acroread viewer.  I've reinstalled both firefox and acrobat
reader 6.02 several times.  No effect.  Files are still opened in the browser
properly in IE.

Reproducible: Always
Steps to Reproduce:
1. Install adobe reader 6
2. Disable all plug-ins
2a. Try to read a pdf.
3. re-enable all plug-ins
5. Try to read a pdf
Actual Results:  
all pdfs are now downloaded in teh download manager and opened externally

Expected Results:  
pdfs should open in the web page.
This is a plugin setting isn't it? Can't you specify that in the Adobe settings?
(Reporter)

Comment 2

13 years ago
The setting for that in acrobat has no effect.

Firefox is now displaying in the browser correctly.  The only thing different
is that the computer sat idle for a few hours.

When the problem occurs, firefox first downloads the file (shows up in the
downloads window), then launches acrobat externally.  When it does not,
acrobat's browser plug-in launches first, then downloads the pdf on its own and
displays it in the browser window.  The behavior difference seems to be coming
from firefox.

Comment 3

13 years ago
I have v similiar issue with numerous installations across various OS.  The file
half loads and then get the message "This document has been closed by acrobat -
press the Refresh button to reload"...which then has the same result.

Used to have a very similar issue in IE which turned out to be a bug in the
Acrobat Plug-in but can't trace the source of the problem here.

Hope that helps.

Comment 4

13 years ago
I have v similiar issue with numerous installations across various OS.  The file
half loads and then get the message "This document has been closed by acrobat -
press the Refresh button to reload"...which then has the same result.

Used to have a very similar issue in IE which turned out to be a bug in the
Acrobat Plug-in but can't trace the source of the problem here.

Hope that helps.
Assignee: bugs → nobody
QA Contact: aebrahim-bmo-507 → file.handling

Comment 5

11 years ago
I'm having a similar problem (Adobe 7.0, Firefox 1.5.0.8 on Suse 9.3).  Up until the security update before last, .pdf's opened in the browser.  Now, it opens a new window with an error message about how Adobe can't launch.  I've checked my plugins numerous times and tried reloading, but still--nothing.  I have to use Konqueror if I want to read .pdf's within the browser; otherwise, I have to save them to disk, open Adobe and then open the saved file.
Reporter, do you still see this problem with the latest Firefox 2 and the latest Acrobat? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.