No way to play audio in SVG on Windows

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: jonathan chetwynd, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041103 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041103 Firefox/0.9.1+

sound file does not play in pc mozilla native.

works for mac firefox native

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
no sound

Expected Results:  
play sound
Do you have a plug-in for audio/mp3 files?

Does it work if you remove the mention of SVG and just use XHTML?

Does it work if you use HTML instead of XML?
OS: MacOS X → Windows 2000
Hardware: Macintosh → PC
(Reporter)

Comment 2

14 years ago
well I had been using wmp, now have installed a plugin.

I have to emphasise once again that for mozilla to be successful sound has to be
supported.

that doesn't mean via a plugin.... it has to be very easy.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Flags: in-testsuite-
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 269915
(Reporter)

Comment 4

11 years ago
jwatt one is windows the other os x, did you check both?
Created attachment 284962 [details]
audio file for test
Created attachment 284963 [details]
testcase

Updated

11 years ago
Resolution: DUPLICATE → WORKSFORME

Updated

11 years ago
Summary: Sound foreignObject embed src → No way to play audio in SVG on Windows
(Reporter)

Comment 7

11 years ago
jwatt,

this attachment does work in mozilla, camino and safari, but not opera (possibly an audio bug, already filed)

the main difference with the test file I atached is the lack of an html and body wrapper.

is this correct? safari works with either....
Did you mean that comment for bug 269915?
(Reporter)

Comment 9

11 years ago
Created attachment 284977 [details]
broken using html and body
(Reporter)

Comment 10

11 years ago
no the attachment is here...
however as you'll appreciate the new attachment is broken.

given that foreignobject is not afaik limited to html, it seems natural to expect the author to specify what the language is.
your example fails to do this...

I believe this bug and the other should remain open, until my original attachment works. unless you have a good rationale, which may well be the case

regards
You said:

> the main difference with the test file I atached is the lack of an html and
> body wrapper.

There was no file that attached to this bug at the time.

The reason your tests don't work is probably that you don't have a plugin to handle mp3. The <body> tag has nothing to do with it.
(Reporter)

Comment 12

11 years ago
the attachment is with the other bug.

jwatt, I have attached a new file to this bug.

it is broken ie doesnt work in os x
whereas your does

the only difference being html and body.

please show a little more care and I think respect.
this has nothing to do with your suggestions
I tried both mp3 and wav files, this is not an issue

regards
(Reporter)

Comment 13

11 years ago
if you believe that my attachment to this bug works for windows, leave closed,

however the other os x bug remains broken if html and body are included as should be clear to yoy by now...

tx
(In reply to comment #12)
> jwatt, I have attached a new file to this bug.
> 
> it is broken ie doesnt work in os x
> whereas your does
> 
> the only difference being html and body.

That's not the only difference with the new file you attached. Your new file references an MP3 whereas mine references a WAV.

> please show a little more care and I think respect.
> this has nothing to do with your suggestions
> I tried both mp3 and wav files, this is not an issue

I did. I took your testcase, changed it to reference my WAV, and it worked. I tested before I made the above statement. It worked (and still works) for me with the html and body. Hence my assertion that it's not the html and the body that's preventing things working for you.
(Reporter)

Comment 15

11 years ago
jwatt,

I do find that you are being obtuse and difficult about this, I already stated this is NOT an issue about wav or mp3.

I downloaded your wav and tested locally, I also tested using the attachmnent on the server.

reminder, this is the os x version... I dont have access to win2000 currently
however may try on xp one day...
(Reporter)

Comment 16

11 years ago
Created attachment 285060 [details]
broken using html body & WAV on os x
(Reporter)

Updated

11 years ago
Attachment #284977 - Attachment is obsolete: true
Created attachment 285061 [details]
peepo's previous test changed to use the attached wav

(In reply to comment #15)
> reminder, this is the os x version... I dont have access to win2000 currently
> however may try on xp one day...

No, this is the windows version. I did say earlier I thought you were commenting on the wrong bug.
Attachment #285060 - Attachment is obsolete: true
Created attachment 285063 [details]
Now with the namespace declaration moved up to the <html> tag
Attachment #285061 - Attachment is obsolete: true
That's your problem. The <html> and <body> were in the SVG namespace, so naturally since these tags aren't defined in SVG, they and their content were ignored.
(Reporter)

Comment 20

11 years ago
jwatt this is plainly getting silly

my original attachment in the other bug that you closed defines html and is broken.


furthermore div is not defined in SVG, yet is not ignored.
As I already said, I took that testcase and changed it to reference the wav, and it works for me on Windows. What's silly is continuing to have discussions about the Mac being broken on the Windows bug. Comment on the Mac bug and I will reply there. I don't intend to reply on this bug again.
(Reporter)

Comment 22

11 years ago
wfm too, but it would have been simpler, had you

A: not closed the OS X bug

B: not marked it as a dupe of this bug

C: used the attachment there, here, rather than some dodgy code that works but should not.

cheers
A: You closed the bug back in 2004 - check the bug history.

B: Marking it as a duplicate was indeed my mistake. I failed to notice the bugs were for different platforms, so with identical subject lines I thought you'd filed two duplicates again (not sure why you needed two per-platform bugs rather than one cross-platform bug).

C: There's nothing "dodgy" about the code I attached - it absolutely should work - and the reason I attached it here was because this is the Windows bug and I have a Windows machine, not a Mac. Perhaps if you'd refrained from insisting on commenting about Mac on the Windows bug you'd have been less confused.
You need to log in before you can comment on or make changes to this bug.