Closed Bug 270498 Opened 17 years ago Closed 16 years ago

bad link to all top rated and all most recent extensions: missing browser type

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: r.baietti, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.3) Gecko/20040910

The (all) top rated and (all) most recent links don't have browser specification
in it, then if you ask for all most recents or all top rated from any browsers
(mozilla, firefox, thunderbird) you go on firefox extensions.

The links
https://update.mozilla.org/extensions/showlist.php?category=Top%20Rated
https://update.mozilla.org/extensions/showlist.php?category=Newest
should be:
https://update.mozilla.org/extensions/showlist.php?application=mozilla&category=Top%20Rated
https://update.mozilla.org/extensions/showlist.php?application=mozilla&category=Newest

Reproducible: Always
Steps to Reproduce:
1.go on https://update.mozilla.org/extensions/?application=mozilla
2.click on Most Recent
[https://update.mozilla.org/extensions/showlist.php?category=Newest]

Actual Results:  
I see fire fox most recent extensions
[https://update.mozilla.org/extensions/showlist.php?category=Newest]

Expected Results:  
I'll should view mozilla most recent extensions
[https://update.mozilla.org/extensions/showlist.php?application=mozilla&category=Newest]
*** Bug 270499 has been marked as a duplicate of this bug. ***
Assignee: psychoticwolf → psychoticwolf
Bulk Moving Web Site bugs to new component.
(Filter: massumowebsitespam)
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
This'll be fixed in update-beta.
Assignee: psychoticwolf → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Now the LiveBookMark icon on
https://update.mozilla.org/extensions/showlist.php?category=Newest is invalid.
Sage fails to find a link on thw page.
On https://update.mozilla.org/faq/?application=firefox the FireFox Extensions
Newest RSS link is invalid and Sage fails to detect a FireFox Newest extensions
feed on that page.

At one point the 'most recent' link (top of RH column)on
https://update.mozilla.org/extensions/?application=firefox was pointing to most
recent Mozilla instead of FireFox but that seems to have cleared for the moment.
RSS seems to work just fine now (in Thunderbird). However the RSS I want the
most (newest Firefox), doesn't:
https://update.mozilla.org/rss/?application=firefox&type=E&list=newest

It now gives the following message:
XML Parsing Error: undefined entity
Location: https://update.mozilla.org/rss/?application=firefox&type=E&list=newest
Line Number 31, Column 36:- Menu Items under 'Go' and 'View--»Sidebar'
Target Milestone: --- → 1.1
Probably related with other browser detection and RSS bugs.
At this moment, the problems which are pointed out in this bug's comments are
not reproducible (fixed in the process of fixing the forementioned related bugs?)
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
The site has changed but the mistake remain: if you from mozilla suite click on
"Newest Mozilla Extensions" the site show you firefox extensions and not mozilla
extensions.

The link to:
https://addons.update.mozilla.org/extensions/showlist.php?category=Newest&numpg=10&pageid=2
has a mistake

The correct link would be:
https://addons.update.mozilla.org/extensions/showlist.php?category=Newest&numpg=10&pageid=2&application=mozilla

Then must be put "&application=mozilla" at the and of the link, without this 
also with mozilla the extension loaded are the firefox extension
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I can confirm that this bug still exists.  The affected links are the ones in
the section headers, not the sidebar links.
This works now.
Status: REOPENED → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.