long list of mail adresses truncated

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: iamthe, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Thunderbird 0.8 and Firefox 1.0PR

Our homepage contains a link to the email adresses of all mebers of this format:

<a href="mailto:a@a.com
?to=b@b.com
&to=c@c.com
...
">This Link</a>

By clicking at it in firefox, thunderbird opens with a new mail window but lists
only the first entries in the to-list. The last entry shown is not valid since
it is truncated right in the middle. The rest of the list is missing completely.
It looks as if the buffer used for the communication between firefox and
thunderbird is limited. And this limit seems to be far too low. I don't know if
it is a problem with firefox or thunderbird or both of them. With Mozilla it
works fine.

Reproducible: Always
Steps to Reproduce:
1. Setup a htm-file with a link to a large number of email adresses (20 or so
should be enough) of the format described above.
2. Click at the link.
3.

Comment 1

13 years ago
Could you post either a URL to the page containing this list, or at least tell 
us how many mail addresses are in your mailto: link?  Or, even better, paste the 
link that doesn't work into the URL field in this bug.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Could you post either a URL to the page containing this list, or at least tell 
> us how many mail addresses are in your mailto: link?  Or, even better, paste the 
> link that doesn't work into the URL field in this bug.

I can't post the URL because of privacy reasons. The list consists of about 40
entries and the truncation appears at the 10th entry. I've tested it once again
and copied the valid part of the list to a file. I think that the limit is close
to 256 bytes.

Comment 3

13 years ago
Adding a test URL to this bug's URL field.  This mailto has 26 addresses and is 
longer than 500 bytes, and I see no truncation via Firefox (1.0) or Opera (7.54) 
when opening a TB 1.0 compose window; Win2K.

Comment 4

13 years ago
No response from reporter; =>WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.