Backspace key bound to delete folder.

RESOLVED DUPLICATE of bug 197439

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 197439
14 years ago
14 years ago

People

(Reporter: Ron Alford, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.5.5 (KHTML, like Gecko) Safari/125.11
Build Identifier: version 0.9 (20041103)

The backspace key is bound as a shortcut to delete the folder if it is in focus.
My specific problem happened when I went back to a folder that I was just in to delete the message I 
just read.
When I clicked on the folder, the message I wanted to delete was highlighted and showing in the 
message box (though it was not focussed).
I hit the delete key, and years of reflex had me hit the return key before the confirm dialog was even 
fully displayed, then poof, my work mail folder was gone in an instant.

Maybe there is a way to let me change delete folder into just an unsubscribe?
At anyrate, it seems odd to have an multiple-use shortcut key to bound to such a drastic function.

Reproducible: Always
Steps to Reproduce:
1. Create a folder, copy a junk piece of mail to it.
2. Select folder, click on message.
3. Go to another folder.
4. Go back to the test folder, watch message be selected, hit delete. Reflexively hit enter.
Actual Results:  
Deleted entire folder.

Expected Results:  
In my preferred order, one of:
1) Nothing
2) Delete selected-but-not-focused message
3) Popped up confirm but not taken 'enter' as a confirm.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 197439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.