Creating multiple addressie list semi-colon separated does not work

RESOLVED DUPLICATE of bug 242693

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 242693
14 years ago
14 years ago

People

(Reporter: Xabier Altube, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When creating a new mail, if you enter multiple addresses separated by
semi-colons ";" it creates an extrange record in the Addressbook.

I thinks that it would be pissitive for the Thunderbird to accept addresses
separated by semi-colons, as thuis is the most used format in other
mail-clients, and this way it woill be aesyer for the people to move from other
to Thunderbird, as they would not need to write in a different way they have
been doing for time...

Reproducible: Always
Steps to Reproduce:
1.write addresses separated by ";"
2.click on send
3.an error message appears and a not valid record is created in the addressbook

Actual Results:  
An error message appears telling that can not send a message to the address
<<>>, and a not valid record is created in the addressbook

Expected Results:  
Act the same way as separating the addresses with commas ",", thats it, split
the line in multiple address lines

Comment 1

14 years ago
The semicolon has a specific use, defined in RFC822, as a group terminator.
This looks like;
   groupname: addr@xx.tld, addr@yy.tld ;     <- semicolon ends group
You'll see this often in the form:
   Undisclosed-Recipients:;

Mozilla does not support groups well, if at all -- bug 83521, bug 110605.
See also bug 94676.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 242693 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.