dialogs shown while dragging are irresponsive

VERIFIED DUPLICATE of bug 100180

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 100180
14 years ago
10 years ago

People

(Reporter: Lucian Sandor, Unassigned)

Tracking

({hang})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

I get a prompt for allowing or blocking cookies and, if I am dragging an anchor
before the dialog is shown, Mozilla gets irresponsive. I cannot choose an option
although the dialog in foreground.
Because it is a modal dialog, I cannot access the rest of the Mozilla windows.
If I try to kill it right-clicking on taskbar, I get a system sound "Default
Beep", as if I would try to close another program with a modal window.
I supposed NVidia Desktop Manager "features" were guilty and I disabled; still,
I was able to reproduce the bug. But anyway I won't exclude a conflict with the
pile of bugs Nvidia calls "latest drivers".
No real crash occurs, but I have to kill Mozilla from task manager, because it
is irresponsive.

Reproducible: Always
Steps to Reproduce:
1. Enable the prompting for cookies.
2. Go to a site which you know would make Mozilla ask you for cookies' permission.
3. Before getting the cookies' permissions dialog , start dragging a link.
4. Release the mouse button.
Actual Results:  
No drag actually occurs. The dialog is unaccesible although it is on the
foreground. Mozilla windows are unaccesible.

Expected Results:  
Dragging the link should produce opening of the link, in the same window and
tab, or in a different (eventually new) tab. I should be allowed then to click
on dialog's elements, like buttons, checkboxes etc.

*** This bug has been marked as a duplicate of 100180 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
V.Duplicate
Status: RESOLVED → VERIFIED
Keywords: hang
You need to log in before you can comment on or make changes to this bug.