status bar text instructions from scripts invoked via onfocus or onblur under keyboard navigation ignored

RESOLVED DUPLICATE of bug 269900

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 269900
13 years ago
13 years ago

People

(Reporter: Foteos Macrides, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041117
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041117

If a script is invoked via a mouseover or mouseout event and includes a focus()
or blur() call for an element whose onfocus or onblur attribute value includes a
status bar text instruction (self.status='foo' or window.status='foo'), the
instruction succeeds.  In contrast, if the same element has its focus or blur
event triggered via keyboard navigation (TAB or Shift-TAB) so that there is no
immediately preceding mouseover or mouseout event, then the status bar text
instruction fails. 

Reproducible: Always
Steps to Reproduce:
1.The testcase has two labeling anchors whose onmouseover attribute values have
a focus() call for their respective text inputs to their right.  It also has
Submit and Reset buttons whose onmouseover attribute values have a focus() call
for themselves. The onfocus attribute values in the text inputs and in the
buttons include status bar text instructions.  First, make sure that "Allow
scripts to change status bar text" is checked for your Gecko-engine browser.
2. Do mouseovers for the labeling anchors and the buttons, and look at the
status bar text as the text inputs or buttons are granted focus.
3. Then grant focus to the text inputs and buttons via keyboard navigation, and
look at the status bar text.

Actual Results:  
The status bar text is changed to that specified by the text inputs' or buttons'
onfocus attribute values only when their focus event is invoked via a mouseover
event (in the labeling anchors, or in the buttons themselves).

Expected Results:  
The status bar text should be set via the script instructions in the onfocus
attribute values no matter how the focus event is invoked, i.e., regardless of
whether it is the consequence of a cursor-based event or keyboard navigation (as
is true for other browsers such as IE and Opera).

This bug and important related matters concerning Bug 133874 (filed almost 3
years ago) are discussed under PROBLEM (4) in the testcase. I had hoped that
setting the status bar text via onfocus and/or onblur during keyboard navigation
might provide a workaround for Bug 133874 (but instead encounterd yet another
problem for keyboard navigators such as folks with disabilities when using Geckos).

The bug is present in the current released versions of Mozilla, Firefox and
Netscape for Windows, and it persists in yesterday's Mozilla 1.8a5 nightly build
(BuildId: 2004111704) for Windows.
(Reporter)

Comment 1

13 years ago
Note that this bug appears to differ from any other outstanding bugs I found
when searching the database concerning scripting via onfocus or onblur because
it is specific to the status bar text instructions during keyboard navigation. 
I thus far have found no other script instructions that fail when invoked by
focus or blur events during keyboard navigation.

For example, see demos

http://www.macridesweb.com/oltest/ONFOCUS.html

and

http://www.macridesweb.com/oltest/hide.html

for some rather elaborate scripting via focus and/or blur events that works with
the Geckos as with other browsers under both curser-based and keyboard navigation.
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 269900 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.