setting home page with "Use Current Page" uses first tab, not active tab

VERIFIED INVALID

Status

()

Firefox
Preferences
--
minor
VERIFIED INVALID
13 years ago
11 years ago

People

(Reporter: deneen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       GoogleBot/2.1 (+http://www.googlebot.com/bot.html)
Build Identifier: Firefox 1.0

setting home page with "Use Current Page" button uses the first tab, not the
active tab

Reproducible: Always
Steps to Reproduce:
1. Open a few tabs with different pages.  
2. Select the right-most tab
3. Tools -> Options -> General -- Click on "Use Current Page"
Actual Results:  
The URL from the left-most tab was used.

Expected Results:  
It should have used the URL from the active tab.
We don't tend to do much work on Googlebot around here, but assuming that your
hypothetical Googlebot browser is fairly similar to Firefox, since at least 0.5
there's been no "Use Current Page" button for setting the home page if you have
more than one tab open, only a "Use Current Page_s_" which sets all the tabs in
that window as your home pages. To set just one, you need to open it in a
separate window, or edit down the multiple URLs to just the one you want.

(By the way, by browsing with your UA set to Googlebot, you are depriving the
Mozilla developers (of whom I'm _not_ one) of one of the very, very few things
that a user can give them: enough Gecko user agents in people's server logs that
they will think twice about doing IE-only things. Please, at least consider only
switching when you need to, not all the time.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
*** Bug 272085 has been marked as a duplicate of this bug. ***
*** Bug 281927 has been marked as a duplicate of this bug. ***
*** Bug 297920 has been marked as a duplicate of this bug. ***
*** Bug 212087 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.