If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cgi scripts open in originating frame, not in the target frame

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: John_Acevedo_, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Using Firefox 1.0 with Windows 2000.
Opening a link from Frame1 with a target=Frame2 works fine for regular links
like http://www.website.com/directions.htm.  But if the link in Frame1 is
executing a Perl script like
http://www.website.com/cgi-bin/cal/calendar.pl?orgdir=engineering with a
target=Frame2, the Perl script works fine but the resulting page opens in Frame1
which is the originating frame, not in Frame2.

The Perl script works as expected – opening in Frame2 - in IE6 and Netscape 4.7.

Firefox is great!  Thank you.

Reproducible: Always
Steps to Reproduce:
1.Click on the (cgi) link in Frame1 which has a target=Frame2
2.
3.

Actual Results:  
Link opens in Frame1 which is the originating frame.  The target was set to Frame2.

Expected Results:  
Open the cgi results page in Frame2

Works fine in IE6 and Netscape 4.7
Can you provide the code that is used as an attachement here? A reduced testcase
would be ideal. I doubt that this is an issue with Firefox.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Can you provide the code that is used as an attachement here? A reduced testcase
> would be ideal. I doubt that this is an issue with Firefox.

I had reproduced this problem for the last few days, but as of today 2004-11-23,
the frame targeting is working fine for the "xxx.pl?xxx" page in question.  The
websites used for testing are mine and I have not changed anything in them.  I
might have updated a couple of Firefox 1.0 extensions, but they would seem to be
unrelated to this frame targeting problem.  I also see quite a few frame
targeting bugs being reported.  But my problem seems to have gone away, like
something has been updated in Firefox, but unknown to me!

Thank you.
-> because of Reporters Comment #2 Resolved as Worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.