All users were logged out of Bugzilla on October 13th, 2018

JavaScript Year 2038 Cookie Problem

VERIFIED DUPLICATE of bug 27070

Status

()

P3
normal
VERIFIED DUPLICATE of bug 27070
19 years ago
19 years ago

People

(Reporter: keith_bowes, Assigned: morse)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
JavaScript cookies that have an expire date after January 18, 2038 won't store
between sessions.

An example of this bug can be found on my home page (the URL above).  The
cookie, set in the left frame, is currently set to expire January 19, 2038, the
day that this bug starts.  If the expire date is set to an earlier date, the
cookie stores as expected; if it is set to the specified or later date, the
cookie doesn't store.

I've tested this bug on build ids 2000012520 and 2000020608 on Windows 98.

Comment 1

19 years ago

*** This bug has been marked as a duplicate of 27070 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.