If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pop-up blocker also blocks pop-up windows that user voluntarily clicks.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: jeff jennings, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When clicking a link that pops up a separate window, thge browser's built-in
pop-up blocker blocks this function.

Reproducible: Always
Steps to Reproduce:
1.  Click any link that brings up a new window.  I wont work
2.
3.

Actual Results:  
nothing.  Browser gives no indication that a window should have popped up.

Expected Results:  
Allowed the window to pop up.  If a user vluntarily clicks it, chances are, it
is NOT a pop-up ad, and therefore should not be blocked.
*** Bug 270735 has been marked as a duplicate of this bug. ***
Well, as reported your bug is simply invalid. If Firefox as-installed just
wouldn't open any links in new windows ever, your report would be the 2
millionth duplicate, not the first ever.

Either you have a broken installation, in which case the support forum at
http://forums.mozillazine.org/viewforum.php?f=38 is the place to go (and be sure
to mention what extensions you've installed and what preferences you've changed,
and what browser's settings you might have imported), or rather than "every
single link targetting a new window" you actually mean "some particular one or
sort of one", in which case you either need to tell us where it is, or use the
"Create a New Attachment" link to upload a minimized testcase that shows it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.