Closed Bug 270743 Opened 17 years ago Closed 17 years ago

First launch account creation doesn't honor unchecking [ ] Download messages now option

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird1.5

People

(Reporter: timeless, Assigned: whimboo)

References

Details

(Keywords: dataloss, fixed1.8)

Attachments

(3 files, 1 obsolete file)

BuildId: 20041118
version: 0.6+ (i dunno what that means, i suppose it's a trunk thing)

Ignoring the fact that I can't get thunderbird to download 400 of my emails.

Steps to reproduce:
1. setup a gmail account (if you need an invite, just ask)
2. setup a bugzilla account with your gmail account
3. make your bugzilla account watch all default owner and qa contacts for
bugzilla.mozilla.org
4. wait 8months
5. login to gmail.com
6. select Settings
7. select Forwarding and POP
8. select (*) Enable POP for all mail (even mail that's already been downloaded)
9. select When messages are accessed with POP [keep Gmail's copy in the Inbox|v].
10. download thunderbird from
http://ftp27f.newaol.com/pub/mozilla.org/thunderbird/nightly/latest-trunk/thunderbird-win32.zip
11. expand it (this is windows xp, so that's simply a copy of the thunderbird
folder from the thunderbird.zip explorer view) to the desktop
12. double click the thunderbird folder
13. double click the thunderbird.exe application
14. (*) Don't import anything
15. next
16. email mail
17. next
18. for name, enter your gmail account name (e.g. timeless)
19. for email address, enter your gmail email address (e.g. timeless@gmail.com)
20. next
21. (*) pop
22. incoming server: pop.gmail.com
23. [ ] Use Global Inbox (...)
24. outgoing server: smtp.gmail.com
25. next
26. Incoming username: enter your gmail email address (e.g. timeless@gmail.com)
27. Outgoing username: enter your gmail email address (e.g. timeless@gmail.com)
28. next
29. next
30. [ ] Download messages now
31. Finish

Expected results:
1. Account is created
2. It's possible to get to account settings so that I can fix the rest of the
account settings ([x] Use secure connection (SSL), [x] leave messages on server,
 [ ] Check for new messages at startup,  [ ] Check for new messages every [...]
minutes, [ ] Automatically download new messages) before it tries to log into
the account.

Actual results:
thunderbird selects the account's inbox after the account is created and tries
to connect to pop.gmail.com

Not that this only happens the first time you create an account, if you delete
the account, quit, run thunderbird again and create an account, it'll honor the
checkbox and leave something else selected (Local Folders).
Thunderbird version 0.9 (20041103)/ Mac OS X 10.3.5

 I see the same behaviour on the Mac. This bug can also be reproduced by
launching Thunderbird with the profile manager [1], creating a new profile and
then starting with the new profile. The above steps 16 onwards are then
identical. Despite the "Download messages now" option being unchecked,
Thunderbird connects to the POP server and asks for the POP account's password
in order to download messages. Cancelling the password dialog will cancel the
connection.

[1] Assuming Thunderbird is in the Applications folder, from the terminal enter
"/Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -profilemanager".
Same here.
Thunderbird version 1.0 (20041206) on Win2003

 - install TB
 - start
 - create a new account
 - deselect "Download messages now"
 - click Finish

Result:
TB tries to contact the server and asks for the password. I canceled this , so I
don't know what it would do exactly.

I see that wehn you create another account, the option "Download messages now"
is not shown anymore. But there is a workaround (as jwq already mentioned ) :
 - exit TB
 - run the profile manager
 - create a new profile
 - start TB with new profile
 - use the account wizard that is opened automatically to reproduce the bug
Confirmed with "Thunderbird version 1.0 (20041226)" on
Win/2K(/nightly/latest-0.9 2004/12/26 build).

When all account settings for the first account definition were correct and
password was properly entered and login was successful,
all mails on POP3 server were downloaded, then all mails were deleted from the
server.
"Server Settings" of the account at this step was:
 - [X] Check for new messages at startup
 - [X] Check for new messages every [10] minutes
 - [X] Automatically download new messages

Workaround-1 : Cancel when password prompt as comment #1 and comment #2 say.

Workaround-2 : (slightly safer way)
 (1) Define the accoutn with dummy(but meaningfull) server name and user name.
     -> Saved in in mail.server.server1.hostname & mail.server.server1.userName.
        Used for internal pathname of mail folders, mail directry name etc.
     -> Attempt of login will never be successful.
 (2) Cancel when password prompt.
 (3-A) Change server name and user name to real ones.
       -> Saved in in mail.server.server1.realhostname &
          mail.server.server1.realuserName, and used for login.
 (3-B) Or use this first(default) account as Global Inbox account,
       and define other accounts of Global Inbox use.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: normal → major
*** Bug 280630 has been marked as a duplicate of this bug. ***
Perhaps worth reiterating that I noticed  Bug 280630 on Mandrake linux 10.1 with
Thunderbird 1.0 ?

And also that this would be almost too trivial to worry about, if it were not
for bug 231541 .
OS: Windows XP → All
*** Bug 282065 has been marked as a duplicate of this bug. ***
(In reply to comment #6)
> *** Bug 282065 has been marked as a duplicate of this bug. ***

Yup, I guess I didn't try hard enough with my search.

HOWEVER, I notice the bug is still marked as 'NEW'.  How does it get to
'Verified' or better yet 'Fixed' status?  Not that it really matters.  The
damage has already been done, and I won't make the same mistake again.  Kinda
leaves a bad taste in your mouth for the whole thing though.  And you're gonna
catch more poor suckers until you fix this.

The big issue really seems to be the default to 'remove messages from server'
functionality.  Another vote: THIS IS JUST PLAIN DESTRUCTIVE.  Give people a
chance to make their own decision about the status of messages on the server. 
Especially those people who are only evaluating the product and now decide they
don't like it a bit, but wait, they don't have thier messages any longer.

But then hey, it IS free. Don't get me wrong, I appreciate the hard work that
went into developing this software; I do it myself for a living.  I just get a
bit incensed when my data is needlessly destroyed. (Yes, I know I still have it
in Thunderbird, but if I had been a bit slower, I might have uninstalled an
deleted, thinking my messages were still on my server.)

(In reply to comment #7)
> Yup, I guess I didn't try hard enough with my search.
Don't feel too bad about it.  I have terrible trouble finding relevant bugs with
the search page, and have often created duplicates (for which I do apologise,
but it's not as though I don't look).  

I still feel that it would be no hardship at all to make 'leave on server
indefiniately ' the initial default, just out of politeness.
I'm seeing this on 1.0.1 builds. 

by the way, a workaround for data loss is to cancel the password dialog when it
appears for the initial account. Then goto account settings and make changes so
that messeges are left on the server.
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.0.1?
Summary: First launch account creation doesn't honor [ ] Download messages now option → First launch account creation doesn't honor unchecking [ ] Download messages now option
not for 1.0.1. leaving open for 1.1 ocnsideration
Flags: blocking-aviary1.0.1?
(In reply to comment #9)
> I'm seeing this on 1.0.1 builds. 
> 
> by the way, a workaround for data loss is to cancel the password dialog when it
> appears for the initial account. Then goto account settings and make changes so
> that messeges are left on the server.

Doesn't help if you don't expect the download because you selected the DON'T
DOWNLOAD option!  And once the download starts, there appears to be no way to
interrupt it short of turning off internet access.  And of course you have to
notice that it did not honor your wishes after you walked away from the machine
for a moment during install.


Absolutely right.  It's only a workaround if you know about it before you make a 
complete mash of your mail sever
Keywords: dataloss
This bug would not be as big of a deal, except that bug #231541 (removes
messages from server by default) exists as well.  I was checking my work email
remotely and thus wanted to leave my messages on the server, yet because of
these two bugs in combination they were all downloaded before I could stop it.
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird1.1
>mscott@mozilla.org changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>             Status|NEW                         |ASSIGNED
>   Target Milestone|---                         |Thunderbird1.1


Coo, well done.  Mackerals will never crease.
Attached patch the fixSplinter Review
I think this was a very subtle regression introduced by changes to support
deferred pop accounts. 

The account wizard sets gLoadStartFolder to false if the user chose to not
download  mail for the POP account. We had code in
msgMail3PaneWindow::loadStartFolder which skipped the call to
defaultServer.PerformBiff if gLoadStartFolder was true

a few lines later we call MsgGetMessagesForAllServers and that behavior changed
to start calling .PerformBiff as part of the deferred server work. The fix is
to  avoid calling MsgGetMessagesForAllServers if gLoadStartFolder is set to
false.
Attachment #178523 - Flags: superreview?(bienvenu)
Comment on attachment 178523 [details] [diff] [review]
the fix

I think this worked when I first did deferred accounts, and I think it
regressed at some point, but I could be wrong...but in any case, I think your
fix should work (I'll try it) but the comment is backwards - if
gLoadStartFolder is false, then we must have come from the new account wizard,
right? In all other cases, it's true.
Attachment #178523 - Flags: superreview?(bienvenu) → superreview+
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
verified with Mac and Windows trunk builds from 03/29
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.1?
*** Bug 299309 has been marked as a duplicate of this bug. ***
Reopening to get an identical fix into SeaMonkey.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attachment #192242 - Flags: superreview?(bienvenu)
Attachment #192242 - Flags: review?(bugzilla)
Attachment #192242 - Flags: superreview?(bienvenu) → superreview+
*** Bug 304176 has been marked as a duplicate of this bug. ***
Comment on attachment 192242 [details] [diff] [review]
identical fix for SeaMonkey 

I don't think this is the right fix.
Attachment #192242 - Flags: review?(bugzilla) → review-
Okay, then reclosing and back to bug 304176.
Sorry for the confusion. :-/
Status: REOPENED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
The patch on bug 304176 has fixed only SeaMonkey. Neil, you forgot the fix for
Thunderbird. I'll come up with a patch immediately.

=> Reopening
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attached patch Fix for trunk (obsolete) — Splinter Review
Assignee: mscott → hskupin
Status: REOPENED → ASSIGNED
Attachment #195650 - Flags: review?(mscott)
I forgot the patch for msgMail3PaneWindow.js
Attachment #195650 - Attachment is obsolete: true
Attachment #195655 - Flags: review?(mscott)
Attachment #195650 - Flags: review?(mscott)
Attachment #195655 - Flags: superreview+
Attachment #195655 - Flags: review?(mscott)
Attachment #195655 - Flags: review+
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Closed: 17 years ago17 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Hardware: PC → All
Target Milestone: Thunderbird1.1 → Thunderbird2.0
Version: unspecified → Trunk
Target Milestone: Thunderbird2.0 → Thunderbird1.5
You need to log in before you can comment on or make changes to this bug.