Gmail steals focus, even across desktops, even if minimized

RESOLVED DUPLICATE of bug 272867

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 272867
13 years ago
11 years ago

People

(Reporter: David, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:fix], URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; i686; en_US) (KHTML, like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

I tend to leave a firefox window open to gmail, and randomly sometimes it will 
steal the focus from whatever I am doing, which is usually Not another firefox 
window, and is often on a different desktop.  It does not matter what state the 
window with the gmail tab is, even if it was minimized it suddenly becomes 
restored, and its desktop suddenly becomes the active one.  This happens 
anywhere from once every few days to once every few minutes. 

Reproducible: Sometimes
Steps to Reproduce:
1. Log into gmail 
2. Do other stuff 
3. wait 
 
Actual Results:  
 


SuSE Linux 9.1 with KDE 3.3.1

Comment 1

13 years ago
WFM (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041123
Firefox/0.9.1+)
But also works with Firefox 1.0

Using KDE 3.3.1 and Slackware 10

Comment 2

13 years ago
The meta refresh that gmail is using causes the keyboard focus to be lost on the
current page, even if you are currently typing something in the current page.  I
don't think this is optimal functionality.  I think in tabbed mode, other tabs
shouldn't be able to steal focus no matter what.  Or atleast make that an option
in preferences/options.

Comment 3

13 years ago
probably related to #278527
happens in Windows too, probably any OS.
Is this still an issue in current trunk build?
http://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-trunk/
There are quite some focus stealing issues fixed, since this bug has been filed.

Comment 5

12 years ago
In the 1.0.7 version?  I haven't tried the 1.5 beta with this yet.  But, yes, it
is still a bug, the other tab steals focus.

Comment 6

12 years ago
Confirm, it is still a bug in the latest ver.
No, not in the 1.0.7 version, in the trunk version. You can download it with the
link I gave you.

Comment 8

12 years ago
Actually I did download the trunk version, and it still had the same bug.  I
tested it on WinXP by loading gmail in one tab, opening a new tab, loading up a
page with some java chat appelet, then sitting there for a little bit, and sure
enough when gmail refreshed the page to check for new mail, it stole the focus.

Updated

12 years ago
Blocks: 140346

Comment 9

12 years ago
Dup of bug 272867?  (Has easier steps to reproduce)
Whiteboard: [sg:fix]

Comment 10

12 years ago

*** This bug has been marked as a duplicate of 272867 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
No longer blocks: 140346
You need to log in before you can comment on or make changes to this bug.