Enhancement request: Shortcut does not bring up main window if secondary window is open

VERIFIED WORKSFORME

Status

Thunderbird
General
--
enhancement
VERIFIED WORKSFORME
14 years ago
11 years ago

People

(Reporter: MonCapitain, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When a secondary window (for reading existing message or compose a new one) is
open, the Thunderbird shortcut does not launch the main window upon clicking on
it. Instead, the main window needs to be activated by selecting
Tools->Mail&Newsgroups or by pressing <CTRL>-1.

Despite this workaround the current behavior is not very user-friendly and not
consistent with other e-mail programs such as Outlook and Outlook Express. For
example, Outlook Express can be launched without any problems when a "compose"
window is open simply through the shortcut or by re-executing the .exe.

This issue has been reported before, e.g. bug226179, but the actual behavior is
still present due to the availability of a workaround. While this is not a bug
per se, it is a user interface issue that should be changed at some point.

Reproducible: Always
Steps to Reproduce:
1. Launch Thunderbird 0.9
2. Press "New" to open up "Compose" window
3. Close the "main" Thunderbird window
4. Click at the Thunderbird shortcut in the Windows quick launch menu

Actual Results:  
The application puts the focus on the existing "Compose" window.

Expected Results:  
The main window should be launched and brought to the foreground.

A quick fix would be to add "-mail" to the shortcuts. However, a better solution
IMHO would be make this the default behavior without having to add any
additional commandline options since the users might have created their own
shortcuts or might launch TB directly through the .exe instead of going through
a shortcut.

Comment 1

14 years ago
I'll confirm this, it's a reasonable request.

I'm not sure how this applies to *nix (Linux, BSD, even Mac); so leaving it as 
an RFE for Windows, for now.
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → General
Ever confirmed: true
OS: Windows XP → Windows 98
Version: unspecified → Trunk

Comment 2

14 years ago
*** Bug 290065 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
WFM trunk versions
windows 2000 version 1.0+ (20050422)
and XP version 1.0+ (20050502)

Comment 4

13 years ago
WFM trunk versions
windows 2000 version 1.0+ (20050422)
and XP version 1.0+ (20050502)

Comment 5

13 years ago
*** Bug 303804 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
I see that this is working, too!  TB 1.0+0806, Win2K.

This fix is not, and will not be, in 1.0.x builds; you need to be running 
pre-1.5 trunk builds (nightlies).  Judging from comment 3, the fix, wherever it 
was, was in place in time for the official 1.1a1 build.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 7

12 years ago
*** Bug 322229 has been marked as a duplicate of this bug. ***

Comment 8

11 years ago
So this bug and Bug 226179 can't be fixed? Been using TB for years and this is first time I ran into this. With TB down, clicked on mailto link and got compose window. Then clicked on TB icon to open the main TB window but just timed out in KDE.

Would never guess to try the Tool/MailNews menu item. Also, if I put -mail on the command I just get another compose window, not the main window. The workaround is non-intuitive. 

This is Thunderbird 1.5.0.9 on Linux.

Comment 9

11 years ago
Your description and that of this bug works in thunderbird v2. Apparently (and not surprisingly) it will not be fixed in v1.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.