bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

The CSS command style="background-repeat: no-repeat" do not work.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Carsten Kanstrup, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Firefox 1.0

The CSS command style="background-repeat: no-repeat" do not work. You will see 
this on the menu background if you compare the web-page www.abigael.dk in EI 
and Firefox. "no-repeat" may not be defined in CSS (only repeat-x, repeat-y 
and repeat-xy are defined in my book), but EI understands "no-repeat" and it 
is the only way to stop repetition since repeat-xy is default.

Reproducible: Always
Steps to Reproduce:
1. Open the specified web page in IE and see how the menues should look like.
2. Compare it with Firefox. You will notice the wrong repetition in the y-
direction.
3.

Actual Results:  
Wrong repetition in the Y-direction until something else is written on the web-
page.

Expected Results:  
No repetition of the background image.

Comment 1

14 years ago
You have put your style rules as seperate html attributes. like this:
<td width="140" style="background-image: URL(menu-bg.jpg)"
                style="background-repeat: no-repeat"
                style="padding-left: 20px">

Only the first rule will be used here. 

You should rather make it like this:
<td width="140" style="background-image: URL(menu-bg.jpg); background-repeat:
no-repeat; style="padding-left: 20px;">

If you still have a problem with this, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.