browser crash when opening tech-report-com.

VERIFIED DUPLICATE of bug 228557

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 228557
13 years ago
12 years ago

People

(Reporter: Craig Green, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

Browser just crashes.

Tech-report.com is one of my daily visits but I've only recently started having
this problem. The only things I've changed recently are installing the
flashblock extension (tech-report has two or three flash ads), and adjusting
some of the networking:http values in about:config.  Specifically,
max-connections to 32, pipelining.maxrequests to 8 and
max-persistent-connections-per-server and -per-proxy (to 4 and 8, respectively).

I have no conclusive evidence for this, but it seems that it crashes more if I
open the page in a fresh window, than in a window that's already displayed
another webpage.  I'll keep an eye out in the future.

This has actually happened on 1.7RC2, 1.7.3, 1.8a4, and Firefox 1.0.  (Firefox
doesn't include talkback?)  I had decided to give 1.8 a whirl and downloaded a
nightly snapshot.  Mailnews was acting funny, so I tried the actual 1.8a4
release.  Same thing, plus crashing with tech-report, so I decided to go back to
"old-faithful" 1.7.  I then noticed I wasn't actually running a 1.7 RC version,
and downloaded the latest in that branch--1.7.3.  It crashed, too, so I reset
the shortcuts to the version I'd used for months.  It crashed, so I gave Firefox
1.0 a whirl.  Ditto, and here I am.

I install each version in its own directory, BTW.  Dunno if that matters, but it
does make switching between versions easier.

Reproducible: Sometimes
Steps to Reproduce:
1. Open browser, or a new window.
2. Enter http://www.tech-report.com in the addressbar.
3. Hit Enter.

Actual Results:  
Browser crashes.  MS "Sorry but this application needs to close, please let MS
know blah blah" box comes up, then the Netscape talkback box.

Expected Results:  
Display the website.

Talkbacks: TB2016191Q, TB2038867M, TB2038875X, TB2038886M, TB2038897G, TB2054882H.

From the talkback viewer, apparently this is an "Access violation" in Module
"gklayout.dll".

Comment 1

13 years ago
WFM on linux. Reporter try a newer nightly build.

Comment 2

13 years ago
Please retry with a profile without flashblock extension, there have been some
problems in the past.

I would suggest to install the latest release, mozilla 1.7.3 from mid of
September, http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.3/
or a current nightly of 1.7 (that is the folder name on the nightlies server,
about: in the location bar will show 1.7.5) 
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-11-19-08-1.7/
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.7/
The 1.7 nightlies donĀ“t have risky fixes, they will give you less bugs and more
stability. The trunk versions are 1.8a5, they will give you new features and new
bugs, as they are alpha versions under development.

Do you use the latest version of flashblock?
See http://flashblock.mozdev.org/
http://flashblock.mozdev.org/installation.html
Almost certainly the flashblock crash, yes... (based on the stacks).
Assignee: dbradley → nobody
Component: XPConnect → Layout
QA Contact: pschwartau → core.layout
Whiteboard: DUPEME
(Reporter)

Comment 4

13 years ago
Per Mitch's suggestion, I updated to the latest nightly, and thence to 1.8a5
when it was released.  The Flashblock extension is installed, but I've yet to
experience another crash.

Updating again, I saw a note on http://flashblock.mozdev.org/installation.html
regarding a crashing bug https://bugzilla.mozilla.org/show_bug.cgi?id=228557
that was fixed.  It specifically says "Webpages known to trigger this bug
include http://techreport.com."

I'm guessing, then, that this bug is essentially a dupe of 228557.

Resolve bug, mark as dupe?

Thanks to those who looked into this for me.

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 228557 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.