IMAP: should postpone downloading of headers as result of unsolicited response

VERIFIED WONTFIX

Status

P3
normal
VERIFIED WONTFIX
19 years ago
11 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

Trunk
Future
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
If we're doing something like downloading a message in the inbox and get an 
unsolicited response that there are new headers, we should postpone downloading 
headers until we've fetched the message.
(Assignee)

Comment 1

19 years ago
moving to m20, accepting.
Status: NEW → ASSIGNED
Target Milestone: M20

Comment 2

19 years ago
*** Bug 27084 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

19 years ago
*** Bug 27084 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: lchiang → huang

Comment 4

19 years ago
enhancement?  If so, will move to future target milestone
(Assignee)

Comment 5

19 years ago
bug is a bit bogus - we don't download headers before downloading a message - 
what happens is sometimes biff fires right before you click on a message, and 
there's not much we can do about that. If you don't like it, turn biff off.
Target Milestone: M20 → Future

Comment 6

19 years ago
Does this impact bug 16545? Users won't always turn biff off.
I did notice that biff are not working correctly for most of IMAP servers:
see bug 37826 for MS Exchange, bug 38346 for Cyrus, bug 38235 for AOL.
(Assignee)

Comment 7

19 years ago
biff is working fine on all those servers, where biff is defined as the 
automatic retrieving of headers at a user-specified interval. All those bugs are 
just in the handling of the green icon, which is not server-specific, and really 
has nothing to do with biff - it's just the indication that a folder has new 
headers since the user last opened that folder, and is also set when the user 
manually downloads new headers by clicking Get Msg or selecting the INBOX.

Comment 8

19 years ago
Agree. I will go ahead to mark those bugs dup of bug 16545.
(Assignee)

Comment 9

18 years ago
resolving wontfix - it's really invalid, as described above but whatever.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 10

17 years ago
Marking as verified based on David's comments 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.