Closed Bug 270832 Opened 15 years ago Closed 7 years ago

Opening multiple urls in tabs with | (pipe) doesn't always work

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3

People

(Reporter: pettijhn, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Depending on the setting for "Open links from other applications in," opening
multiple urls separated by | (pipe) doesn't always open new tabs. If the setting
is "a new window," it works as expected: another application requesting that
Firefox open "http://www.siteone.com/|http://www.sitetwo.com/" opens a new
window with the two urls, each in its own tab. If the setting is "a new tab in
the most recent window," a single new tab opens in the most recent window,
treating the pipe-separated urls as a single URL, usually resulting in a 404
from siteone.com.

Reproducible: Always
Steps to Reproduce:
1. Set "Open links from other applications in" to "a new tab in the most recent
window."
2. Open a link in another application (in XP, Start -> Run) with multiple urls
separated by | (pipe), like "http://www.google.com/|http://www.yahoo.com/"

Actual Results:  
Firefox will open a single new tab on the most recent window, attempting to open
the multiple URLs as a single URL. Google will give you a 404 that it could not
find "/%7Chttp://www.yahoo.com/"

Expected Results:  
Two new tabs should have been opened in the current window, one with
http://www.google.com, the other with http://www.yahoo.com.
I found this to be true when trying to set my preferences for several tabs to be
opened automatically when I load Firefox 1.0 (under Tools->Options). The last
url specified in the list always ends up with the 404 message because the url
that is passed to the browser is all messed up.
Well, I seem to have fixed the version of this bug that I had been experiencing
(indicated in my earlier post from this evening). I first set my home page to be
"blank" in the Tools->Options menu, and restarted Firefox. I then opened up the
number of tabs I wanted for my home page "group", loaded the respective pages,
and then in Tools->Options menu told Firefox to use the "Current Pages". After
closing Firefox, I re-opened it and the correct pages were loaded in tabs. 

But, the pipe doesn't work at all in my installation (when I enter it manually
in the url bar).
It's a bug that pipes in URLs from other applications sometimes cause Firefox to
open multiple tabs.  Real URLs can and do contain pipes.
My previous comment should have included a link to bug 221445.
Assignee: bugs → nobody
Fixed by bug 441120 (by disallowing opening multiple tabs via the command line).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
You need to log in before you can comment on or make changes to this bug.