If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

osnews.com - Text zooming causes improportionately skewed page layout

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
13 years ago
3 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041119 Firefox/0.9.1+

In the COMMENTS section of any news story on http://www.osnews.com, text-
zooming (zoom-in) creates an improportionately large gap between the comments 
section and the category menu.  This makes it difficult to navigate the site 
while reading.  This problem does not exist in IE, Opera, Safari, or Konq. 

I've contacted the admins of the site; they agree that it's a Firefox or Gecko-
specific bug.

A screenshot illustrating the problem is available at:
http://mercury.easternct.edu/b/bernabeom/web/gap_in_comments.jpg

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.osnews.com
2. Enter a COMMENTS section of any news story
3. Use the ZOOM function, and zoom-in deeply on the text.

Actual Results:  
A large gap appears between the comments section and the category menu.

Expected Results:  
The category menu (left) and the comments (right) should be *MUCH* closer 
together.

The bug occurs when using the default (or ANY) theme.  I've observed this bug 
on multiple x86 machines, running Linux and Windows.

Comment 1

13 years ago
Created attachment 166507 [details]
Screen Shot with stuff to Illistrate what's happening

Comment 2

13 years ago
The main section of the page has a table with 2 cells next to each other (Shaded
in Red and Green in my screen shot)

<TEXTAREA NAME="forum_text" (the text box for your comments) increases in size
when you increase the text size. This casuses the Right hand column (Red shaded
area) to increase in width.

The comments are contained in set width, right allined tables within this right
hand side cell. Removing either of these properties will solve this problem.

I'm moving this bug to TE, and assigning it to you Mike. Armed with this
information I'm hoping you can convince the site owner, and get them to change this.

If you don't agree with me moving it to TE, you can change it back, but please
change it to "Browser" "Layout", not "FireFox" "Web Site" (this is for is for
http://www.mozilla.org/products/firefox/)
Assignee: bugs → digitalwhoopass
Status: UNCONFIRMED → NEW
Component: Web Site → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism

Comment 3

13 years ago
Miguel, please re-open the bug and put it under "Browser" "Layout"

Gary, I won't be changing the OSNews layout, because this breaks other, older
browsers (e.g. Opera under BeOS). That cell is aligned right for a reason. :)

I also tried IE and Opera and when you increase the font size it changes the
textarea accordingly. Gecko instead, it increases it very dis-porportionally,
resulting in destroying the layout in general. The layout would be bad in other
sites as well, not just OSNews. So, there is no reason to change OSNews layout,
but instead to fix the Gecko engine, as this is a bug.

Comment 4

13 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new

QA, when you move a bug to TE, please follow the reporting guidelines.
Summary: Text zooming causes improportionately skewed page rendering → osnews.com - Text zooming causes improportionately skewed page rendering
(Reporter)

Comment 5

13 years ago
Moving bug to "Browser" "Layout" area, per the discussion above.
Component: English US → Layout
Product: Tech Evangelism → Browser
Summary: osnews.com - Text zooming causes improportionately skewed page rendering → osnews.com - Text zooming causes improportionately skewed page layout
Version: unspecified → 1.7 Branch

Comment 6

13 years ago
saying you're not going to change a site does not make this a Mozilla bug. 
Furthermore, Mozilla should not go around emulating broken browsers to make your
site that you have specifically written to work around their bugs.

Sending this back to Evang.  This is a layout bug only if you can produce a
minimal testcase that shows the problem you think exists (and it's a real problem).

why not just style the textarea with "width: 500px"
Assignee: digitalwhoopass → english-us
Component: Layout → English US
Product: Browser → Tech Evangelism
QA Contact: english-us
Version: 1.7 Branch → unspecified

Comment 7

13 years ago
>saying you're not going to change a site does not make this a Mozilla bug. 

The form textarea grows disporportionally to the rest of the page. This changes
the layout to something that the webmaster never intended to. Therefore, it is a
bug.

Comment 8

13 years ago
> The form textarea grows disporportionally to the rest of the page

The HTML specifies that the form textarea is to be 60 columns wide.  Is it not
still 60 columns wide (of a bigger font) at high zoom?  The font at normal zoom
in the textarea (courier) is a bit wider than the font on the rest of the page
(a proportional font) and this remains true at high zoom.

Comment 9

4 years ago
Bug no longer exists. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.