[Regression] Japanese msg display is broken

VERIFIED FIXED

Status

P3
critical
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Build: 2000020908 linux commercial build.

The Japanese msg display is totally broken: Japanese subject is displayed blank in the thread pane. 
Japanese mail body is displayed as garbage. 

Steps of reproduce:
1. Download and unzip the smoketest mail folder from the above URL.
2. Put it in your  mail directory.
3. Select the 2nd, 3rd for 4th msg in the mail folder.
(Reporter)

Comment 1

19 years ago
On the compose window, the Japanese chars in the subject and mail body are garbled too.
Sender field displays okay. For the new msg composed using this build, the subject
is not displayed blank in the thread pane. Both subject and sender in Japanese are garbled in the thread pane.
(Assignee)

Comment 2

19 years ago
Adding rhp and mscott to cc.
(Reporter)

Comment 3

19 years ago
Filed another bug for the display problem on the mail compose window: Bug 27099.

Comment 4

19 years ago
Added beta1 keyword.
Keywords: beta1
(Reporter)

Comment 5

19 years ago
On today's build, all non-ASCII web pages are displayed as garbage. (please see bug 27105).
The problem discribed here could be caused by the same reason.

Comment 6

19 years ago
the nsURLProperties.cpp changes warren check in cause this. puttermann's change 
fix it.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

19 years ago
Verified/fixed with 2000021008 linux build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.