Painting is sometimes postponed until mouse moves

RESOLVED DUPLICATE of bug 267557

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 267557
13 years ago
13 years ago

People

(Reporter: Ronald Tilby, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041119
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041119

Viewing photo Galleries at CNN.com, sometimes the window painting is postponed,
resulting in a blank window UNTIL the user moves the mouse.

Reproducible: Always
Steps to Reproduce:
1.go to url
2.move the mouse pointer to the 'Next' button.
3.While holding the mouse perfectly still, left-click the 'Next' button


Actual Results:  
The window goes blank until you move the mouse.  Keyboard activity doesn't
appear to trigger the painting.  This failure is not 100%, but for me it is
upwards of 70%.

Expected Results:  
Display the 'Next' picture and accompanying text.

I have produced this problem on Windows 2000 and Windows XP using Windows Trunk
Nightly builds.
The regression window is:
Windows Trunk Nightly 2004102906 - Pass
Windows Trunk Nightly 2004103006 - Fail

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041119

I see a series of 6 images,
the first one:
http://i.cnn.net/cnn/interactive/world/0408/gallery.sudan.ap/gal.01.sudan.ap.jpg

the last one:
http://i.cnn.net/cnn/interactive/world/0408/gallery.sudan.ap/gal.06.sudan.ap.jpg

If you see the last one, and click next, this bug can be seen.
I didnĀ“t see it on any other transition, only from last to first image.

Comment 2

13 years ago
Confirming bug, 1 hour old clean CVS trunk build on Linux. Tried the patch in
bug 267557 but it did not help in this case.
Status: UNCONFIRMED → NEW
Depends on: 267557
Ever confirmed: true
OS: Windows XP → All

Updated

13 years ago
Keywords: regression

Comment 3

13 years ago
OK, with the additional patch in bug 269402 this works fine...

*** This bug has been marked as a duplicate of 267557 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
No longer depends on: 267557
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.