Closed Bug 270936 Opened 16 years ago Closed 15 years ago

accents do not work in fastfind (typeahead / find as you type)

Categories

(Toolkit :: Find Toolbar, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.8final

People

(Reporter: zouave, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ca-AD; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ca-AD; rv:1.7.5) Gecko/20041108 Firefox/1.0

Since Firefox 1.0PR1, fastfind won't recognise accented characters. The
characters aren't even written in the fastfind bar's text field.

I can reproduce the problem in Firefox 1.0 for Linux and OS X. Have not tested
other versions.

Reproducible: Always
Steps to Reproduce:
1. Load a page with accented characters. 
2. Press the slash key to begin fastfind search.
3. Type an accented character, such as "ó".

Actual Results:  
The fastfind bar pops up, but no character is written in the textfield.

Expected Results:  
The "ó" character should have been written in the textfield and searched in the
page.

- This bug is NOT present when using the find (not fastfind) bar.
- Fastfind works with other latin characters, such as "ñ".
I'm seeing the problem (OS X, FF 1.0) with all characters that use a "dead key"
(a key for  the accent, followed by the vowel to be accented).
This was also reported (for Linux) in bug 251891 comment 39. That bug is now
resolved as a duplicate of a bug 259454, which is Japanese-specific. So I don't
think this bug should be duped to any of those.

Also see bug 260433 which was duped to 251891, but might actually describe this
problem.
OS: MacOS X → All
Hardware: Macintosh → All
Bug 260433, about spanish characters was duped to bug 259454, so it might be
related/dupe.
All the special character bugs with FAYT are being duped to that one, so this
should be no different. The likely result is that the patch there will fix it.
if not, then those issues will be addressed there.

*** This bug has been marked as a duplicate of 259454 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Gavin: The only reason bug 251891 was duped to bug 259454 was that it was the
only left issue, no more dupes there.
Status: RESOLVED → UNCONFIRMED
Depends on: 259454
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 1.0 Branch
I fixed bug 259454.
Maybe, this problem is gone. Please check it with next nightly build.
thanks.
I cannot reproduce with CA locale and Spanish keyboard layout.
I thinkt that this is fixed by bug 259454.

-> FIXED
Status: NEW → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.1
Version: 1.0 Branch → Trunk
*** Bug 302534 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.