Crash if i visit the above with javascript enabled for browsing [@ nsCSSCompressedDataBlock::MapRuleInfoInto]

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: bgp, Assigned: dbaron)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041113

When i visit www.terkepbank.hu I get a reproducible crash with the newest
nightly build. Java isn't enabled (though the site apparently uses that), just
JavaScript.


Reproducible: Always
Steps to Reproduce:
1.enable javascript
2.type www.terkepbank.hu in the URL
3.

Actual Results:  
Crash

Expected Results:  
No crash

Comment 1

13 years ago
WFM (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0)

Updated

13 years ago

Comment 2

13 years ago
I visited the page. There is a map applet in the lower left frame. While it is
loading, my cpu is maxed and it stays around 40% once the applet is loaded. I
loaded the frame into a single tab (with right click and load frame into tab)
and tried the applet and I crashed twice. Because of bug 210251, I couldn't send
a Talkback Incident report accordingly.

I think the component (as filed in this bug report) is wrong: I would be very
surprised if this bug has anything to do with javascript.

Mozilla 1.8a5 build 2004111704 under XP Pro SP2 with the latest JRE 1.5.0-b64.

Reporter, do you crash if you try with Java disabled? 
What is the version of your JRE?

Comment 3

13 years ago
> Reporter, do you crash if you try with Java disabled?

Um, the reporter specifically said Java was disabled.

bgp: can you submit a talkback report for the crash?  This worksforme with linux
trunk 2004111905

==> BG
Assignee: general → general
Component: JavaScript Engine → Browser-General
Keywords: crash
QA Contact: pschwartau → general
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041113
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041113
> 
> When i visit www.terkepbank.hu I get a reproducible crash with the newest
> nightly build. Java isn't enabled (though the site apparently uses that), just
> JavaScript.
> 
> 
It crashes too in Firefox :-(
> Reproducible: Always
> Steps to Reproduce:
> 1.enable javascript
> 2.type www.terkepbank.hu in the URL
> 3.
> 
> Actual Results:  
> Crash
> 
> Expected Results:  
> No crash

Comment 5

13 years ago
TB2076348Y
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB2076348Y
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041119

Loading the page with JS enabled, Java disabled, didn´t crash, even when I was
looking around over there, scrolling, usoing links and selects.
I closed the tab, enabled Java, loaded the page again, and got a crash.
DocWatson came up, collecting data for a while, and then the applet started
rendering the city map. I closed DocWatson, and Mozilla closed itself. No
Talkback comming up.
I started Mozilla again, loaded the page, and crashed, this time TRalkback
comming up. 
When I started Mozilla again to copy&paste the bug and the URL to the comment, I
erroneously submitted the talkback.

Re comment 2:
"Because of bug 210251, I couldn't send a Talkback Incident report accordingly."
Bugs can still arrive, when you you don´t get back a talkbackID.
Once I sent a Talkback, it seemed to me that sending succeeded, but I had no ID,
and couldn´t retransmit. Searching for the URL I had commented, I found my
talkback on the talkback server. Seems, if a ID was given, the same report isn´t
accepted on retry.

I´m using zip builds, and I´ve got to delete components/compreg.dat, to get
talkback working.

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 267462 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

13 years ago
Well, i got JRE 1.5.0 but Java is disabled (at edit/preferences/advanced/java)
in my browser. I don't deny that it is a JRE specific problem, but I wonder how
it gets control if Java is disabled.

Comment 8

13 years ago
bgp: can you try without java installed at all and/or submit a talkback report?
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> bgp: can you try without java installed at all and/or submit a talkback report?

I've done this:
 Uninstalled JRE: rpm -e jre
 Checked it by running a java application (didn't run)
 Checked edit/preferences/advanced/java (was disabled)
 Went to www.terkepbank.hu (crash)

With all my knowledge this is a JavaScript problem, because when i turn off
JavaScript, the problem doesn't happen.

Talkback ID: TB2113432Q
(Sorry, i'm a newbie can't link it simply here).
(Reporter)

Comment 10

13 years ago
this one belongs to me too (but this time jre was still installed, though java
disabled):
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=2077396
Product: Browser → Seamonkey
(Reporter)

Comment 11

13 years ago
(In reply to comment #6)
> 
> *** This bug has been marked as a duplicate of 267462 ***

No, this isn't a duplicate.
My report is about: no java enabled/installed. Only in Mozilla (not in Firefox)
an d under Linux. It is a 100% crasher with those parameters.

The alleged duplicate is mostly about Java/Firefox/Windows combo. I don't have
any of those!
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 12

13 years ago
> The alleged duplicate is mostly about Java/Firefox/Windows combo. I don't have
> any of those!

Most bugs are cross-platform (affecting all hardware / OS combos) and plugins
are shared between Firefox and Seamonkey, so product doesn't really matter. 
Java may or may not be explicitly required for the other bug (it was crashing in
layout)

Anyway this is still WORKSFORME (linux trunk 2003051905).  The talkback incident
you submitted before went stale, so it's inaccessible.  Can you submit another
talkback report with a recent trunk build?
(Reporter)

Comment 13

13 years ago
Yes, I sent in a new talkback report. The incident ID is TB4501465G
Generated with Build ID 2005032005

On the very same machine i also have a stock v1.0.1 Firefox which doesn't crash.

Comment 14

13 years ago
Created attachment 178136 [details]
stacktrace for TB4501465G

Comment 15

13 years ago
style system
Assignee: general → dbaron
Component: General → Style System (CSS)
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Summary: Crash if i visit the above with javascript enabled for browsing → Crash if i visit the above with javascript enabled for browsing [@ nsCSSCompressedDataBlock::MapRuleInfoInto]
(Reporter)

Comment 16

13 years ago
*** Bug 280421 has been marked as a duplicate of this bug. ***

Comment 17

13 years ago
do you have any extensions installed?
(Reporter)

Comment 18

13 years ago
(In reply to comment #17)
> do you have any extensions installed?

None, i used to have the shockwave flash plugin, but the crash occurs without it
too. This is a vanilla install.
(Reporter)

Comment 19

13 years ago
This bug and #280421 seem to be fixed in Mozilla 20050611.
Probably fixed before, my last tested non working version was: 20050320.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Comment 20

13 years ago
Bug 280421 was marked as a duplicate of this bug (so it didn't fix this).  There
was no patch checked into this bug, nor any referenced to a patch or other bug
that might have fixed it.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsCSSCompressedDataBlock::MapRuleInfoInto]
You need to log in before you can comment on or make changes to this bug.