Closed Bug 27096 Opened 20 years ago Closed 20 years ago

[Regression] Character set menu is broken

Categories

(Core :: Internationalization, defect, P3, blocker)

All
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: teruko, Assigned: cata)

References

()

Details

When you go to the URL and change character set menu to Japanese (EUC-JP), the Japanese is displayed as garbage.

Steps of reproduce
1. Launch Mozilla
2. Go to above URL
3. Select menu View|Character set Mulibyte -> Japanese (EUC-JP)
   Or Select menu View|Character set -> Japanese (EUC-JP)

Japanese characters are displayed as garbage.

I tested the different non-meta charaset page.  Character set menu does not work at all.

Tested 20000908 Linux build.
Keywords: beta1
Summary: Character set menu is broken → [Regression] Character set menu is broken
Hardware: PC → All
*** Bug 27106 has been marked as a duplicate of this bug. ***
*** Bug 27106 has been marked as a duplicate of this bug. ***
This has nothing to do with my work. Someone else's screw-up. Sux. I am pulling 
a fresh tree and I'll investigate.
Severity: major → blocker
the nsURLProperties.cpp changes warren check in cause this. puttermann's change 
fix it.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I verified this in 200021008 Linux build.  Blee verified this in 2000021008 Win 32 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.