Problems with local filenames that use Japanese text

RESOLVED DUPLICATE of bug 263570

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 263570
14 years ago
14 years ago

People

(Reporter: Josh Smith, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If I try to open local files with Japanese filenames within the browser,
everything works fine (except that the filename in the Navigation bar is
garbage, which is something I can live with), but if I try to open them
externally (e.g., in Windows Explorer), I get the following message:

The file
/c:/[PATH]/[garbage in a hex format like %90%B6%80... etc.]
cannot be found. Please check the location and try again.

I assume this applies not only to Japanese, but to other non-Western
charactersets as well.

As I said, I can open the files within the browser just fine, so this is at
worst a minor annoyance, but I'd like to hear if there's a fix, and if not, I'd
like to bring it to the developers' attention. I haven't tried getting the
Japanese browser, but I'd really prefer to work for the most part in English, as
it's my native language.

I'm using Mozilla Firefox 1.0 English version on Japanese Windows XP

Reproducible: Always
Steps to Reproduce:
1. Create a file with a Japanese filename or locate a file with such a filename
that's associated with Firefox
2. Try to open said file through Windows Explorer or My Computer
3. Done, and Done.

Actual Results:  
error message: 
the file
/c:/[PATH]/[garbage in a hex format like %90%B6%80... etc.]
cannot be found. Please check the location and try again.

Expected Results:  
correct opening of file

Comment 1

14 years ago
Feel free to reopen the bug if it is not like bug 263570 comment 11.

*** This bug has been marked as a duplicate of 263570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.