firefox won't start when using user agent switching and java

VERIFIED DUPLICATE of bug 83376

Status

defect
--
critical
VERIFIED DUPLICATE of bug 83376
15 years ago
7 years ago

People

(Reporter: spam, Assigned: blackconnect)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0
Build Identifier: Mozilla/4

With Firefox 1.0, if you use the user agent switching extension to change it for
a msie agent string, and then exit: next time you start up again, Java gives a
nasty message about how this is the netscape plugin, and it shouldn't be used
with firefox... upon clickingthe box away, firefox stays in memory, absorbing
all availible resources. 

This was easily remedyed by editing the prefs.js file in the firefox profile
directory, but I doubt granny would figure it out :)

Reproducible: Always
Steps to Reproduce:
1. install firefox (1.0)
2. install the user agent switcher extension and java engine
3. use user agent witcher to pretent to be IE
4. exit and watch it eat all your recources :)



Expected Results:  
just told java it's a mozilla thingie and get on with whatever it's supposed to load

Comment 1

15 years ago
(In reply to comment #0)

telling the plugin and the website your are some sort of IE is known to give
funny results.

> This was easily remedyed by editing the prefs.js file in the firefox profile
> directory, but I doubt granny would figure it out :)

What is your solution to this problem, what is your remedy?
Just do, what granny can´t do, delete the fake userstring?
She won´t have installed a UA switcher, so I don´t think, it´s a problem of
granny. She will give you good advice not to install UA switcher, and read the
release notes.

Did you find a workaround how to use Java with a User Agent switcher?
Would be nice to know, so Firefox can be improved.

Comment 2

15 years ago
see bug 270939 comment 2

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.