[Regression] iso-8859-1 is used for collation charset under Ja locale.

VERIFIED FIXED

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2000020908 commercial build.

On the console window, after launching mozilla, it gives the charset information used for mail collation.
For example, if you bring up mail in Ja locale, it will say the initialize mLocale is Ja and the 
initialize mCharset is Euc_JP. It used to give the correct info for Ja locale. 
But today's build (2000020908) says the initialize mCharset is iso-8859-1.

Since the charset menu is broken too (please see Teruko's bug: 27096), could it be the same cause?
(Assignee)

Comment 1

18 years ago
Adding putterman@netscape.com to cc.
Scott, any recent change in this area? The debug out mentioned here dumps the 
locale passed to the collation interface.
Ji, do you know exact build which started this problem?
(Reporter)

Comment 2

18 years ago
It started from today's build (2000020908). Yesterday's build (2000020817) doesn't have this problem.

Comment 3

18 years ago
I haven't changed anything recently except for that fix for Sender last week.

Updated

18 years ago
Keywords: beta1

Comment 4

18 years ago
the nsURLProperties.cpp changes warren check in cause this. puttermann's change 
fix it.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

18 years ago
Verified/fixed with 2000021008 linux build.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.