Firefox acting weird with css headers

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Aaron Slunt, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041114 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041114 Firefox/1.0

The css file in the URL is not automatically handled by firefox: it asks the end
user what to do with it. However, on the link, http://www.tvland.com/shows/, the
file is loaded as CSS, and the javascript console for the web developer toolbar
says the file was gave a warning that the file was loaded as CSS, even though
the mime-type header for the file was application/x-pointplus.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Firefox handles the same file in two different ways, most likely from ignoring
mime-type headers

Expected Results:  
Loaded the file as application/x-pointplus

Comment 1

13 years ago
application/x-pointplus is not correct for CSS files, so everything happening
here is correct behavior.

When you link directly to the CSS, FF wants to download it because it does
handle x-pointplus files natively.

The warnings on the page using CSS are warnings that the MIME type is wrong. 
Since the page renders in quirks mode, we let the CSS load.  If the page was in
standards mode, the CSS would have been disregarded because of the incorrect
mime type.

->Invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.