On shutdown, Saving draft of compose window prevents shutdown



14 years ago
8 years ago


(Reporter: Mike Cowperthwaite, Unassigned)



Thunderbird 3.0rc1
Bug Flags:
blocking-thunderbird3 -
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)




14 years ago
version 0.9+ (20041112) (but I've seen this since TB0.7 if not earlier)

When I shutdown TB, and have a compose window open, I am prompted to save the 
draft.  If I respond Cancel, the shutdown is properly halted and both windows 
remain open.  If I respond Don't Save, the draft is not saved and both windows 

But if I respond Save, the draft is saved, the compose window closes, but the 
main window remains open.

Reproducible: always
Steps to reproduce:
1) Start TB
2) Open a compose window, type something in ti
3) From TB main window, select File | Exit
4) At prompt, click Save

Actual results:
draft saved, compose window closes, main window remains open

Expected results:
draft saved, both windows close

Comment 1

12 years ago
WFM TB trunk

Comment 2

12 years ago
Steps to reproduce still show the problem: TB 3a1-0625, Win2K.
Version: unspecified → Trunk

Comment 3

12 years ago
odd. tried again no dice.
me w2k - version 3 alpha 1 (20060608).
my TB profile has saved passwords for the accounts, no prompts.

config related perhaps?
QA Contact: general

Comment 4

11 years ago
any better with current trunk?

Comment 5

11 years ago
Yes, this seems to have been addressed, somehow, in the trunk; and, for that matter, in 2.0.
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 6

10 years ago
I'm seeing this again (3pre-0308); not sure what might be different.  I do know that the message had already been auto-saved as a Draft.  If I get some time to play with it, I'll test more in-depth.
Resolution: WORKSFORME → ---

Comment 7

10 years ago
yes, I also see this. (2008031402) and 070803. Doesn't fail on 070614.  Perhaps Thorsten would like to take a stab at narrowing the regression range to a one day range?

BTW, this process reliably causes subsequent thunderbird shutdown to hang (a different problem?) - a rather annoying trunk behavior similar to Bug 420744 New: thunderbird hangs on shutdown. Hang doesn't happen with 070803. And I'm unable cause (2008031402) to hang with this STR.
Assignee: mscott → nobody
Keywords: regression

Comment 8

10 years ago
Wayne, I tried several builds. 

Build 070718 is the last one, which is ok.
Build 070719 is the first one, which shows this problem.

I hope that helps you more.

Comment 9

10 years ago
Hmm, here's what sticks out for me (neither makes sense as a possible cause - but I don't know the code)
- Bug 387677 – "Check for new message every x minutes" stopped working for POP3. r+sr=bienvenu 
- Bug #319778 --> upgrade our version of hunspell to 1.1.8


Comment 10

10 years ago
regression of bug 386002 – Move tryToClose calls on shutdown
Flags: blocking-thunderbird3?

Comment 11

10 years ago
reproducible on linux?
Keywords: qawanted

Comment 12

10 years ago
Yes, linux too.


10 years ago
Keywords: qawanted
OS: Windows 2000 → All
Hardware: PC → All

Comment 13

10 years ago
(In reply to comment #10)
> regression of bug 386002 – Move tryToClose calls on shutdown
Blocks: 386002
Marking as blocking-thunderbird3+, since this is a regression.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Assignee: nobody → clarkbw
If I'm understanding the failure mode (having to close again), I don't think this would really block tb3, so moving to wanted.
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3-
Flags: blocking-thunderbird3+
Priority: -- → P3
Target Milestone: --- → Thunderbird 3.0rc1
I'm not working directly on this, so removing myself.
Assignee: clarkbw → nobody

Comment 17

8 years ago
Mike, can you reproduce using 3.1 or 3.0?

WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2pre) Gecko/20100121 Lanikai/3.1b1pre

Comment 18

8 years ago
Yes, can reproduce with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100111 Thunderbird/3.0.1

No, cannot reproduce with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100217 Lanikai/3.1b1pre
Last Resolved: 11 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.