taking long time (and wasting memory) to click "remove (delete?)" in download manager

RESOLVED DUPLICATE of bug 273244

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 273244
13 years ago
10 years ago

People

(Reporter: mki_open, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.7.5) Gecko/20041108 Firefox/1.0

# I'm sorry that this is the second report.   If the first one (which 
# was sent 10 hours ago) is delivered, I aporogize it. 

I'm using ja-JP version of Firefox 1.0 (release), so I'm afraid that this 
problem happens in ja-JP (Japanese) version only. 

When I clicked "remove (delete?)" on a right side of the download manager 
in order to remove a selected file which was downloaded (or saved with Ctrl+S) 
from a file list, sometimes it was done for a short time, but sometimes it 
took for a long time with access to HDD. 
# Of couse, the "remove" is translated into Japanese ("SAKUJO"), so "remove 
# (delete?)" is my guess of the button in Firefox English version. 

In some cases the time duration was about 1 minite, so it is OK for me to wait 
until it was done.    But, in some case, HDD was accessed for one or more 
hours and a memory was wasted till (near) limit of virtual memory with access 
HDD. 
(In my memory, it was the occasion when I was removing a saved html file from 
the file list of the download manager.) 
# At the case, I stopped Firefox from Task Manager. 

I'm afraid that a memory leak or something happens. 
Or, since (I think) a registory is manipulated, I'm afraid that the 
manipulation causes this problem.    (But, if so, I'm not sure that the reason 
of this problem is caused by Firefox or by Windows 2000 itself...)

The reason of the manipulating registory is that there is some place which has 
a relationship information of a saved file and a directory (folder) of the 
file: e.g. if a web page of "node1.html" is saved, image files and a CSS file 
are saved in a directory of "node1_files". And, when the "node1.html" is 
deleted (removed) on Explorer, the "node1_files" directory is also deleted. 


Reproducible: Sometimes
Steps to Reproduce:
1. Install .../ja-JP/Firefox Setup 1.0.exe  :-p
   (Is it necesary to be ja-JP version?)
2. Download a file, or save a web page. 
3. Show Download Manager (Ctrl+J), and click "SAKUJO" which means "remove". 

Actual Results:  
In some case, a window of "being a small virtual memory (?)" (translation of 
it into Japanese) appears.
Duping to a bug with a clearer description.

*** This bug has been marked as a duplicate of 273244 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.