Closed Bug 271139 Opened 15 years ago Closed 15 years ago

background-color of div not painted when absolute positioned to the right of window width

Categories

(Core :: Web Painting, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 201897

People

(Reporter: poindexter, Assigned: roc)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

NOTE: I've also reproduced this with Firefox/1.0

A div that is positioned to the right of the browser's viewing area won't have
it's background-color painted. If the div is positioned with half of it's
content in the viewing area and half of it's content outside of the viewing
area, the content in the viewing area will have it's background-color painted.

In the linked example you should see two divs, one with the content 'H' is
painted correctly, the other with the content 'Q' is missing it's background.

NOTE: this isn't a problem for divs positioned further down the page (i.e. where
you would need to move the vertical scroll bar to see them)

Reproducible: Always
Steps to Reproduce:
1. position div with a visible background-color (i used red) far to the right
(large 'left' value)
2. view page with div, move horizontal scrollbar until div is viewable
3. div will not have it's background-color painted

Actual Results:  
div did not have it's background-color painted

Expected Results:  
div should have appropriate background-color painted regardless of it's position
in the page
The background color is not painted because the div's width is 0.

*** This bug has been marked as a duplicate of 201897 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.