Open Web Location... causes mozilla to hang

VERIFIED DUPLICATE of bug 19255

Status

P3
normal
VERIFIED DUPLICATE of bug 19255
19 years ago
14 years ago

People

(Reporter: sarnold, Assigned: don)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Howdy. Using a build based on tuesday 02/08/00 CVS, the Open Web Location dialog
has not worked properly. I have seen two different actions, but can reproduce
only one of them at the moment.

To reproduce: click on File|Open Web Location...
Result on my computer: mozilla must be killed.

If you get the actual dialog box, try entering a location into the dialog, and
then hit "OK" -- the two times I saw the dialog box, and did this, I had to kill
mozilla.

HTH :)

Comment 1

19 years ago
Sarah, might you know who should receive this bug?
QA Contact: elig → sairuh
h'm, i don't see this using today's comm bits on linux [2000-02-09-08].

what URL are you going to?
Assignee: shuang → don
Component: UE/UI → XPApps
(Reporter)

Comment 3

19 years ago
Hmm. When testing it again, I was able to load http://www.mozilla.org into the
current window; well, it tried anyway. After ~45 seconds, it stopped trying,
having displayed only the splash banner.  (I am on ethernet, so it really
shouldn't be going slowly. :)

So, I tried http://www.google.com into a new browser window, and *poof*
segfault. It left behind this on my console.

It might be tied to the "open in new window" button. I recall now that the
previous times it crashed, I used that button. (I did under m12 with no problems...)

I will try to remember to test this bug again with today's cvs -- give me about
ten hours to test that, perhaps.

Thanks :)


WEBSHELL+ = 7
Move window by 319.5,96
screen x 1screen y 23
WEBSHELL+ = 8
WEBSHELL+ = 9
WEBSHELL- = 8
WEBSHELL- = 7
assuming d&d is off for Navigator
Scheduling later attempt to set content window
Loading page specified via openDialog
Check if a view source window

(Reporter)

Comment 4

19 years ago
Ok, more information.

This sequence of steps caused me to think mozilla had hung:

1) Open mozilla. 2) Open a new browser window. 3) File|Open Web Location in the
new browser window.

This actually *does* open the correct dialog box, but ... it isn't visible, and
the other browser windows stop responding to input. So, if you use your window
manager's functions to change to other windows (for me, middle mouse button on
the root window -- using window maker) the dialog box will be visible, and it
seems to work as expected, once visible.

This is using a build of 02/09/00 CVS.
(Reporter)

Comment 5

19 years ago
This bug is getting a bit annoying -- I switched to the sawmill window manager,
and now I cannot get the OpenWebLocation dialog box to appear on screen at all.
At least with window maker I could get access to the dialog box again, but not
with sawmill. I don't know how the window is being opened, but please change it
so the dialog box is opened on screen. :) Without access to the dialog box,
mozilla is useless, and this might as well be consider a crasher. :)

:)

I added the "beta1" keyword, maybe the PDT team will agree, maybe they won't. :)
Keywords: beta1
(Reporter)

Comment 6

19 years ago
See also bug 28594 -- likely a dup, and that one takes place under Win98.

Comment 7

19 years ago
I've just done some testing with build 2000022708 on Win98, and Open Web 
Location is always-on-top and doesn't interfere with other browser windows.
(Reporter)

Comment 8

19 years ago
*sigh* ccherlin, count your blessings. :) It is very annoying to have to kill a
process that isn't dead, but just won't give you a dialog box. :)

I just retested, and reconfirmed, this is a problem with february 27th CVS.
sarnold@willamette.edu: h'm, i cannot repro this using today's opt comm bits
2000022808. what i do is (1) open a new browser window (File > New Nav window),
(2) File > Open Web Location (in this 2nd navigator window), (3) enter a url
(eg, http://www.google.com/), click Open button. result: the webpage loads, no
crashing or hanging...

i'm not running Sawmill (am running Elightenment in gnome). also running Redhat
linux (kernel v2.2.12-20).

pavlov, you're running Sawmill, can you repro this?
(Reporter)

Comment 10

19 years ago
Sairuh, what are these "opt comm bits"? :) hehe.

I do believe I configure with --enable-optimize, but .. I could be wrong. Is
this the same thing?

Thanks :) (BTW -- it didn't look like pavlov got a CC: from you (based on my
headers..))

:)

Comment 11

19 years ago
in ~/.mozilla/profilename/ try deleting localstore.rdf and see if it comes up on
screen.  there is an open bug somewhere about bringing dialogs up on screen... 
I think it is assigned to Chris Saari

Comment 12

19 years ago
This is a combination of bug 19255 (which allows a modal window to fall behind 
other windows, which then go dead for no apparent reason) and bug 26834 (which 
allows a new window to show up offscreen). Killing as a duplicate of the one 
scheduled last.


*** This bug has been marked as a duplicate of 19255 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

19 years ago
danm, deleting ~/.mozilla/mozProfile/localstore.rdf seems to have fixed the
problem -- Open Web Location works fine now, the Search|Find on page works again
-- of course, I have tested only a few times, but at least now when it goes AWOL
I can fix it! :)

Thank you. :)
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.